# CVE-2017-14775: Laravel Sensitive Data Exposure

> Attackers can exploit timing side-channels in Laravel's remember_me token verification to bypass authentication checks.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-c2v7-j5gq-wcq4

## What is CVE-2017-14775?

CVE-2017-14775 is a medium-severity vulnerability in n/a, published on 27 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-14775?

4 open source packages ship an affected version, including illuminate/auth and laravel/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `illuminate/auth` | Packagist | All versions | 5.5.10 |
| `illuminate/auth` | Packagist | All versions | 5.5.10 |
| `laravel/framework` | Packagist | All versions | 5.5.10 |
| `laravel/framework` | Packagist | All versions | 5.5.10 |

Products: Laravel Laravel.

## How do I fix CVE-2017-14775?

Upgrade illuminate/auth to 5.5.10 or later.

## Is CVE-2017-14775 being exploited?

There is no known exploitation of CVE-2017-14775 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-15133](https://insights.sbomify.com/CVE-2018-15133/): Laravel Deserialization of Untrusted Data (high 8.1, exploited in the wild)
- [CVE-2021-28254](https://insights.sbomify.com/CVE-2021-28254/): Deserialization in n/a (critical 9.8)
- [CVE-2020-24940](https://insights.sbomify.com/CVE-2020-24940/): Guard bypass in Eloquent models affecting Laravel illuminate database component (high 7.5)
- [CVE-2020-24941](https://insights.sbomify.com/CVE-2020-24941/): Improper Input Validation in Laravel (high 7.5)
- [CVE-2017-16894](https://insights.sbomify.com/CVE-2017-16894/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14775 and fix it if it is affected.

What it is: CVE-2017-14775 is a medium-severity vulnerability in n/a, published on 27 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-14775 in the wild and no public exploit code.

Affected packages and fixed versions:
- illuminate/auth (Packagist): affected all versions; fixed in 5.5.10
- illuminate/auth (Packagist): affected all versions; fixed in 5.5.10
- laravel/framework (Packagist): affected all versions; fixed in 5.5.10
- laravel/framework (Packagist): affected all versions; fixed in 5.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14775/ (Markdown: https://insights.sbomify.com/CVE-2017-14775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14775
- OSV: https://osv.dev/vulnerability/CVE-2017-14775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14775/
Summaries are generated and may contain mistakes; the official description above is the record.
