{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-14804 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-14804 is a critical path traversal vulnerability in Opensuse Leap, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-14804 and fix it if it is affected.\n\nWhat it is: CVE-2017-14804 is a critical path traversal vulnerability in Opensuse Leap, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-14804 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-14804/ (Markdown: https://insights.sbomify.com/CVE-2017-14804/index.md)","id":"CVE-2017-14804","markdown":"https://insights.sbomify.com/CVE-2017-14804/index.md","name":"CVE-2017-14804","record":{"aliases":["DEBIAN-CVE-2017-14804","GHSA-q7c2-6g86-6v93","SUSE-SU-2019:0387-1","UBUNTU-CVE-2017-14804","openSUSE-SU-2019:0232-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Build package tool","requires_auth":"low_privilege","summary":"Attackers can exploit directory traversal in the build package to write files outside the intended buildroot, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"linux_enterprise_software_development_kit","vendor":"suse"}],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The build package before 20171128 did not check directory names during extraction of build results that allowed untrusted builds to write outside of the target system,allowing escape out of buildroots.","ecosystems":["SUSE:Linux Enterprise Module for Development Tools 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","suse:linux_enterprise_software_development_kit"],"type":"path_traversal","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Insecure handling of repodata and packages in SUSE Studio onlite","id":"CVE-2017-14806"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Development Tools 15","fixed":["20190128-3.3.2"],"introduced":["0"],"last_affected":[],"package":"build","purl":"pkg:rpm/suse/build\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Development%20Tools%2015","source":"SUSE-SU-2019:0387-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["20190128-lp150.2.3.1"],"introduced":["0"],"last_affected":[],"package":"build","purl":"pkg:rpm/opensuse/build\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:0232-1"}],"prev":{"headline":"Code injection in NetIQ Access Manager","id":"CVE-2017-14803"},"products":["build"],"published":"2018-03-01","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["SUSE"]},"summary":"Attackers can exploit directory traversal in the build package to write files outside the intended buildroot, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2017-14804/"}