# CVE-2017-14868: Restlet Framework Ja-rs extension is vulnerable to XXE when using SimpleXMLProvider

> Remote attackers can access arbitrary files via XXE in REST API requests when using SimpleXMLProvider in Restlet Framework.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2mp8-qvqm-3xwq, UBUNTU-CVE-2017-14868

## What is CVE-2017-14868?

CVE-2017-14868 is a high-severity vulnerability in n/a, published on 30 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Restlet Framework before 2.3.11, when using SimpleXMLProvider, allows remote attackers to access arbitrary files via an XXE attack in a REST API HTTP request. This affects use of the Jax-rs extension.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2017-14868?

2 open source packages ship an affected version, including org.restlet.jse:org.restlet.ext.jaxrs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.restlet.jse:org.restlet.ext.jaxrs` | Maven | All versions | 2.3.11 |
| `org.restlet.jse:org.restlet.ext.jaxrs` | Maven | All versions | 2.3.11 |

Products: Restlet Restlet.

## How do I fix CVE-2017-14868?

Upgrade org.restlet.jse:org.restlet.ext.jaxrs to 2.3.11 or later.

## Is CVE-2017-14868 being exploited?

There is no known exploitation of CVE-2017-14868 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-14949](https://insights.sbomify.com/CVE-2017-14949/): Restlet Framework allows remote attackers to access arbitrary files via a crafted REST API HTTP request (high 7.5)
- [CVE-2013-4221](https://insights.sbomify.com/CVE-2013-4221/): Restlet is vulnerable to Arbitrary Java Code Execution via crafted XML (high 7.5)
- [CVE-2013-4271](https://insights.sbomify.com/CVE-2013-4271/): Restlet Arbitrary Java Code Execution via a serialized object (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14868 and fix it if it is affected.

What it is: CVE-2017-14868 is a high-severity vulnerability in n/a, published on 30 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-14868 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.restlet.jse:org.restlet.ext.jaxrs (Maven): affected all versions; fixed in 2.3.11
- org.restlet.jse:org.restlet.ext.jaxrs (Maven): affected all versions; fixed in 2.3.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14868/ (Markdown: https://insights.sbomify.com/CVE-2017-14868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14868
- OSV: https://osv.dev/vulnerability/CVE-2017-14868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14868/
Summaries are generated and may contain mistakes; the official description above is the record.
