# CVE-2017-14920: eGroupware Community Edition Stored XSS vulnerability

> Unauthenticated attackers can inject JavaScript via the User-Agent header, leading to stored XSS when administrators view the data.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qfg7-wc25-r3j2

## What is CVE-2017-14920?

CVE-2017-14920 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Stored XSS vulnerability in eGroupware Community Edition before 16.1.20170922 allows an unauthenticated remote attacker to inject JavaScript via the User-Agent HTTP header, which is mishandled during rendering by the application administrator.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-14920?

2 open source packages ship an affected version, including egroupware/egroupware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `egroupware/egroupware` | Packagist | All versions | 16.1.20170922 |
| `egroupware/egroupware` | Packagist | All versions | 16.1.20170922 |

Products: Egroupware Egroupware.

## How do I fix CVE-2017-14920?

Upgrade egroupware/egroupware to 16.1.20170922 or later.

## Is CVE-2017-14920 being exploited?

There is no known exploitation of CVE-2017-14920 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-2041](https://insights.sbomify.com/CVE-2008-2041/): Code injection in n/a (critical 10.0)
- [CVE-2007-3154](https://insights.sbomify.com/CVE-2007-3154/): Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packa (critical 10.0)
- [CVE-2007-3155](https://insights.sbomify.com/CVE-2007-3155/): Other in n/a (critical 10.0)
- [CVE-2026-22243](https://insights.sbomify.com/CVE-2026-22243/): EGroupware has SQL Injection in Nextmatch Filter Processing (high 8.7)
- [CVE-2014-2988](https://insights.sbomify.com/CVE-2014-2988/): Code injection in n/a (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14920 and fix it if it is affected.

What it is: CVE-2017-14920 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-14920 in the wild and no public exploit code.

Affected packages and fixed versions:
- egroupware/egroupware (Packagist): affected all versions; fixed in 16.1.20170922
- egroupware/egroupware (Packagist): affected all versions; fixed in 16.1.20170922

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14920/ (Markdown: https://insights.sbomify.com/CVE-2017-14920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14920
- OSV: https://osv.dev/vulnerability/CVE-2017-14920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14920/
Summaries are generated and may contain mistakes; the official description above is the record.
