{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-14970 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-14970 is a medium-severity denial of service vulnerability in n/a, published on 1 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-14970 and fix it if it is affected.\n\nWhat it is: CVE-2017-14970 is a medium-severity denial of service vulnerability in n/a, published on 1 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-14970 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-14970/ (Markdown: https://insights.sbomify.com/CVE-2017-14970/index.md)","id":"CVE-2017-14970","markdown":"https://insights.sbomify.com/CVE-2017-14970/index.md","name":"CVE-2017-14970","record":{"aliases":["DEBIAN-CVE-2017-14970","GHSA-jjh9-mpf5-64ww","SUSE-SU-2017:3232-1","UBUNTU-CVE-2017-14970"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Open vSwitch","requires_auth":"none","summary":"Malformed OpenFlow messages cause memory leaks in Open vSwitch, potentially leading to denial of service, though exploitation requires controller access.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openvswitch","vendor":"openvswitch"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-772","name":"Missing Release of Resource after Effective Lifetime"}],"description":"In lib/ofp-util.c in Open vSwitch (OvS) before 2.8.1, there are multiple memory leaks while parsing malformed OpenFlow group mod messages. NOTE: the vendor disputes the relevance of this report, stating \"it can only be triggered by an OpenFlow controller, but OpenFlow controllers have much more direct and powerful ways to force Open vSwitch to allocate memory, such as by inserting flows into the flow table.\"","ecosystems":["SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2017-14970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2017-14971"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["2.7.0-3.10.1"],"introduced":["0"],"last_affected":[],"package":"openvswitch","purl":"pkg:rpm/suse/openvswitch\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2017:3232-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["2.7.0-3.10.1"],"introduced":["0"],"last_affected":[],"package":"openvswitch","purl":"pkg:rpm/suse/openvswitch\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2017:3232-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-14969"},"products":["n/a"],"published":"2017-10-01","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-9264","kev_date_added":null,"published":"2017-05-29"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-9265","kev_date_added":null,"published":"2017-05-29"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2016-2074","kev_date_added":null,"published":"2016-07-03"},{"cvss_score":8.8,"headline":"Integer overflow in n/a","id":"CVE-2016-10377","kev_date_added":null,"published":"2017-05-29"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2024-22563","kev_date_added":null,"published":"2024-01-19"},{"cvss_score":7.1,"headline":"Openvswitch don't match packets on nd_target field","id":"CVE-2023-5366","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":6.5,"headline":"Denial of service in n/a","id":"CVE-2017-9263","kev_date_added":null,"published":"2017-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Malformed OpenFlow messages cause memory leaks in Open vSwitch, potentially leading to denial of service, though exploitation requires controller access.","url":"https://insights.sbomify.com/CVE-2017-14970/"}