{"answers":{"affected":"3 open source packages ship an affected version, including github.com/vbatts/tar-split. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-14992 in the wild and no public exploit code.","fix":"Upgrade github.com/vbatts/tar-split to 0.10.2 or later.","what":"CVE-2017-14992 is a medium-severity denial of service vulnerability in n/a, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-14992 and fix it if it is affected.\n\nWhat it is: CVE-2017-14992 is a medium-severity denial of service vulnerability in n/a, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-14992 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/vbatts/tar-split (Go): affected all versions; fixed in 0.10.2\n- github.com/vbatts/tar-split (Go): affected all versions; fixed in 0.10.2\n- github.com/vbatts/tar-split (Go): affected all versions; fixed in 0.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-14992/ (Markdown: https://insights.sbomify.com/CVE-2017-14992/index.md)","id":"CVE-2017-14992","markdown":"https://insights.sbomify.com/CVE-2017-14992/index.md","name":"CVE-2017-14992","record":{"aliases":["DEBIAN-CVE-2017-14992","GHSA-hqwh-8xv9-42hw","GO-2025-3640","UBUNTU-CVE-2017-14992"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Docker container engine","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in Docker-CE by sending crafted image layer payloads due to lack of content verification.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"docker","vendor":"docker"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Lack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3, 17.03.0, 17.03.1, 17.03.2, 17.06.0, 17.06.1, 17.06.2, 17.09.0, and earlier allows a remote attacker to cause a Denial of Service via a crafted image layer payload, aka gzip bombing.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tar-split memory exhaustion","id":"CVE-2017-14992","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-14993"},"packages":[{"ecosystem":"Go","fixed":["0.10.2"],"introduced":["0"],"last_affected":[],"package":"github.com/vbatts/tar-split","purl":null,"source":"GHSA-hqwh-8xv9-42hw"},{"ecosystem":"Go","fixed":["0.10.2"],"introduced":["0"],"last_affected":[],"package":"github.com/vbatts/tar-split","purl":"pkg:golang/github.com/vbatts/tar-split","source":"GHSA-hqwh-8xv9-42hw"},{"ecosystem":"Go","fixed":["0.10.2"],"introduced":["0"],"last_affected":[],"package":"github.com/vbatts/tar-split","purl":"pkg:golang/github.com/vbatts/tar-split","source":"GO-2025-3640"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2017-14991"},"products":["n/a"],"published":"2017-11-01","related":[{"cvss_score":10,"headline":"Arbitrary Code Execution","id":"CVE-2014-9357","kev_date_added":null,"published":"2014-12-16"},{"cvss_score":8.8,"headline":"Privilege escalation in Docker","id":"CVE-2020-14298","kev_date_added":null,"published":"2020-07-13"},{"cvss_score":8.8,"headline":"Privilege escalation in Docker","id":"CVE-2020-14300","kev_date_added":null,"published":"2020-07-13"},{"cvss_score":8.8,"headline":"Deserialization in n/a","id":"CVE-2018-15514","kev_date_added":null,"published":"2018-09-01"},{"cvss_score":8.6,"headline":"Path Traversal in Docker","id":"CVE-2014-9356","kev_date_added":null,"published":"2019-12-02"},{"cvss_score":8.4,"headline":"Command injection in n/a","id":"CVE-2019-13139","kev_date_added":null,"published":"2019-08-22"},{"cvss_score":8.1,"headline":"Other in n/a","id":"CVE-2014-5282","kev_date_added":null,"published":"2018-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in Docker-CE by sending crafted image layer payloads due to lack of content verification.","url":"https://insights.sbomify.com/CVE-2017-14992/"}