# CVE-2017-15010: Regular Expression Denial of Service in tough-cookie

> An attacker can cause excessive CPU consumption in applications using the tough-cookie module by sending specially crafted cookies.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** CLSA-2026-1792164172, CVE-2017-16112, DEBIAN-CVE-2017-15010, GHSA-g7q5-pjjr-gqvp, RHSA-2017:2913, UBUNTU-CVE-2017-15010

## What is CVE-2017-15010?

CVE-2017-15010 is a high-severity denial of service vulnerability in n/a, published on 3 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A ReDoS (regular expression denial of service) flaw was found in the tough-cookie module before 2.3.3 for Node.js. An attacker that is able to make an HTTP request using a specially crafted cookie may cause the application to consume an excessive amount of CPU.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-15010?

2 open source packages ship an affected version, including tough-cookie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tough-cookie` | npm | All versions | 2.3.3 |
| `tough-cookie` | npm | All versions | 2.3.3 |
| `rh-nodejs6-nodejs-tough-cookie` | Red Hat:rhel_software_collections:2::el6 | All versions | 0:2.3.3-1.el6 |
| `rh-nodejs6-nodejs-tough-cookie` | Red Hat:rhel_software_collections:2::el7 | All versions | 0:2.3.3-1.el7 |

Products: Salesforce Tough-Cookie.

## How do I fix CVE-2017-15010?

Upgrade tough-cookie to 2.3.3 or later.

## Is CVE-2017-15010 being exploited?

There is no known exploitation of CVE-2017-15010 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-26136](https://insights.sbomify.com/CVE-2023-26136/): tough-cookie Prototype Pollution vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15010 and fix it if it is affected.

What it is: CVE-2017-15010 is a high-severity denial of service vulnerability in n/a, published on 3 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15010 in the wild and no public exploit code.

Affected packages and fixed versions:
- tough-cookie (npm): affected all versions; fixed in 2.3.3
- tough-cookie (npm): affected all versions; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15010/ (Markdown: https://insights.sbomify.com/CVE-2017-15010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15010
- OSV: https://osv.dev/vulnerability/CVE-2017-15010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15010/
Summaries are generated and may contain mistakes; the official description above is the record.
