CVE-2017-15041 Command injection in n/a
Attackers can execute arbitrary commands on a developer's machine by tricking the Go toolchain into reusing a malicious Git checkout during package fetching.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-15041?
CVE-2017-15041 is a critical command injection vulnerability in Debian Debian Linux, published on 5 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Go before 1.8.4 and 1.9.x before 1.9.1 allows "go get" remote command execution. Using custom domains, it is possible to arrange things so that example.com/pkg1 points to a Subversion repository but example.com/pkg1/pkg2 points to a Git repository. If the Subversion repository includes a Git checkout in its pkg2 directory and some other work is done to ensure the proper ordering of operations, "go get" can be tricked into reusing this Git checkout for the fetch of code from pkg2. If the Subversion repository's Git checkout has malicious commands in .git/hooks/, they will execute on the system running "go get."
Which versions are affected by CVE-2017-15041?
1 open source package ship an affected version, including toolchain. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
toolchain Go | All versions | 1.8.4, 1.9.1 |
Products include Debian Debian Linux, Golang Go, Redhat Developer Tools, Redhat Enterprise Linux Eus, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus and 1 more.
How do I fix CVE-2017-15041?
Upgrade toolchain to a fixed version for your release line: 1.8.4 or 1.9.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2017-15041 being exploited?
There is no known exploitation of CVE-2017-15041 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DLA-1148-1, GHSA-2w49-qg9p-7jxx, GO-2022-0177, UBUNTU-CVE-2017-15041.