# CVE-2017-15041: Command injection in n/a

> Attackers can execute arbitrary commands on a developer's machine by tricking the Go toolchain into reusing a malicious Git checkout during package fetching.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DLA-1148-1, GHSA-2w49-qg9p-7jxx, GO-2022-0177, UBUNTU-CVE-2017-15041

## What is CVE-2017-15041?

CVE-2017-15041 is a critical command injection vulnerability in Debian Debian Linux, published on 5 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go before 1.8.4 and 1.9.x before 1.9.1 allows "go get" remote command execution. Using custom domains, it is possible to arrange things so that example.com/pkg1 points to a Subversion repository but example.com/pkg1/pkg2 points to a Git repository. If the Subversion repository includes a Git checkout in its pkg2 directory and some other work is done to ensure the proper ordering of operations, "go get" can be tricked into reusing this Git checkout for the fetch of code from pkg2. If the Subversion repository's Git checkout has malicious commands in .git/hooks/, they will execute on the system running "go get."

## Which versions are affected by CVE-2017-15041?

1 open source package ship an affected version, including toolchain. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toolchain` | Go | All versions | 1.8.4, 1.9.1 |

Products: Debian Debian Linux, Golang Go, Redhat Developer Tools, Redhat Enterprise Linux Eus, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Tus.

## How do I fix CVE-2017-15041?

Upgrade toolchain to a fixed version for your release line: 1.8.4 or 1.9.1.

## Is CVE-2017-15041 being exploited?

There is no known exploitation of CVE-2017-15041 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15041 and fix it if it is affected.

What it is: CVE-2017-15041 is a critical command injection vulnerability in Debian Debian Linux, published on 5 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15041 in the wild and no public exploit code.

Affected packages and fixed versions:
- toolchain (Go): affected all versions; fixed in 1.8.4, 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15041/ (Markdown: https://insights.sbomify.com/CVE-2017-15041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15041
- OSV: https://osv.dev/vulnerability/CVE-2017-15041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15041/
Summaries are generated and may contain mistakes; the official description above is the record.
