# CVE-2017-15089: Deserialization of Untrusted Data in Infinispan

> An authenticated attacker can inject malicious objects into the cache to trigger unsafe deserialization in the Hotrod client, potentially leading to code execution.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-46r5-59fg-2fjc

## What is CVE-2017-15089?

CVE-2017-15089 is a high-severity unsafe deserialization vulnerability in infinispan, published on 15 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It was found that the Hotrod client in Infinispan before 9.2.0.CR1 would unsafely read deserialized data on information from the cache. An authenticated attacker could inject a malicious object into the data cache and attain deserialization on the client, and possibly conduct further attacks.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-15089?

2 open source packages ship an affected version, including org.infinispan:infinispan-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.infinispan:infinispan-core` | Maven | All versions | 9.2.0.CR1 |
| `org.infinispan:infinispan-core` | Maven | All versions | 9.2.0.CR1 |

Products: Infinispan Infinispan.

## How do I fix CVE-2017-15089?

Upgrade org.infinispan:infinispan-core to 9.2.0.CR1 or later.

## Is CVE-2017-15089 being exploited?

There is no known exploitation of CVE-2017-15089 in the wild and no public exploit code.

## Other vulnerabilities in infinispan

- [CVE-2018-1131](https://insights.sbomify.com/CVE-2018-1131/): Deserialization of Untrusted Data in Infinispan (high 8.8)
- [CVE-2019-10174](https://insights.sbomify.com/CVE-2019-10174/): Use of Externally-Controlled Input to Select Classes or Code in Infinispan (high 7.5)
- [CVE-2023-5384](https://insights.sbomify.com/CVE-2023-5384/): Infinispan: credentials returned from configuration as clear text (high 7.2)
- [CVE-2023-3628](https://insights.sbomify.com/CVE-2023-3628/): Infispan: rest bulk ops don't check permissions (medium 6.5)
- [CVE-2020-25711](https://insights.sbomify.com/CVE-2020-25711/): Improper Access Control in infinispan-server-runtime (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15089 and fix it if it is affected.

What it is: CVE-2017-15089 is a high-severity unsafe deserialization vulnerability in infinispan, published on 15 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15089 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.infinispan:infinispan-core (Maven): affected all versions; fixed in 9.2.0.CR1
- org.infinispan:infinispan-core (Maven): affected all versions; fixed in 9.2.0.CR1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15089/ (Markdown: https://insights.sbomify.com/CVE-2017-15089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15089
- OSV: https://osv.dev/vulnerability/CVE-2017-15089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15089/
Summaries are generated and may contain mistakes; the official description above is the record.
