# CVE-2017-15095: jackson-databind vulnerable to deserialization flaw leading to unauthenticated remote code execution

> An unauthenticated attacker can execute arbitrary code by sending malicious input to the ObjectMapper readValue method in jackson-databind.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2018
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-ZL21597, DEBIAN-CVE-2017-15095, DSA-4037-1, GHSA-h592-38cm-4ggp, MGASA-2017-0408, RHSA-2017:3189, RHSA-2017:3190, ROOT-APP-MAVEN-CVE-2017-15095, UBUNTU-CVE-2017-15095

## What is CVE-2017-15095?

CVE-2017-15095 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A deserialization flaw was discovered in the jackson-databind in versions before 2.8.10 and 2.9.1, which could allow an unauthenticated user to perform code execution by sending the maliciously crafted input to the readValue method of the ObjectMapper. This issue extends the previous flaw CVE-2017-7525 by blacklisting more classes that could be used maliciously.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2017-15095?

8 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 24 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.7.9.2 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.7.9.2 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.4 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.4 |
| `rh-eclipse47-jackson-databind` | Red Hat:devtools:2::el7 | All versions | 0:2.7.6-3.3.el7 |
| `rh-eclipse47-jackson-databind-javadoc` | Red Hat:devtools:2::el7 | All versions | 0:2.7.6-3.3.el7 |
| `rh-eclipse46-jackson-databind` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:2.6.3-2.4.el7 |
| `rh-eclipse46-jackson-databind-javadoc` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:2.6.3-2.4.el7 |

Products: Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Oncommand Balance, Netapp Oncommand Performance Manager, Netapp Oncommand Shift, Netapp Snapcenter, Oracle Banking Platform, Oracle Clusterware, Oracle Communications Billing and Revenue Management, Oracle Communications Diameter Signaling Router, Oracle Communications Instant Messaging Server, Oracle Database Server, Oracle Enterprise Manager for Virtualization, Oracle Financial Services Analytical Applications Infrastructure, Oracle Global Lifecycle Management Opatchauto, Oracle Identity Manager, Oracle Jd Edwards Enterpriseone Tools, Oracle Primavera Unifier, Oracle Utilities Advanced Spatial and Operational Analytics, Oracle Webcenter Portal and 4 more.

## How do I fix CVE-2017-15095?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.7.9.2, 2.8.11 or 2.9.4.

## Is CVE-2017-15095 being exploited?

There is no known exploitation of CVE-2017-15095 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15095 and fix it if it is affected.

What it is: CVE-2017-15095 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 6 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15095 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.7.9.2
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.7.9.2
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.4
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15095/ (Markdown: https://insights.sbomify.com/CVE-2017-15095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15095
- OSV: https://osv.dev/vulnerability/CVE-2017-15095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15095/
Summaries are generated and may contain mistakes; the official description above is the record.
