{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-15108 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-15108 is a high-severity command injection vulnerability in Debian Debian Linux, published on 20 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15108 and fix it if it is affected.\n\nWhat it is: CVE-2017-15108 is a high-severity command injection vulnerability in Debian Debian Linux, published on 20 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15108 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15108/ (Markdown: https://insights.sbomify.com/CVE-2017-15108/index.md)","id":"CVE-2017-15108","markdown":"https://insights.sbomify.com/CVE-2017-15108/index.md","name":"CVE-2017-15108","record":{"aliases":["DEBIAN-CVE-2017-15108","GHSA-rx22-vq3w-89rg","MGASA-2019-0032","SUSE-SU-2018:0372-1","UBUNTU-CVE-2017-15108"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"SPICE virtualization agent","requires_auth":"low_privilege","summary":"Local attackers can execute arbitrary commands via improper escaping in the save directory path of the SPICE virtualization agent.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"spice-vdagent","vendor":"spice-space"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"spice-vdagent up to and including 0.17.0 does not properly escape save directory before passing to shell, allowing local attacker with access to the session the agent runs in to inject arbitrary commands to be executed.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP2","SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 12 SP2","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in spice-vdagent","id":"CVE-2017-15108","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"command_injection","year":"2017"},"n_packages":7,"n_references":3,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-15109"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP2","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP2","source":"SUSE-SU-2018:0372-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:0372-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2","source":"SUSE-SU-2018:0372-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:0372-1"},{"ecosystem":"SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20Raspberry%20Pi%2012%20SP2","source":"SUSE-SU-2018:0372-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2018:0372-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["0.16.0-8.5.15"],"introduced":["0"],"last_affected":[],"package":"spice-vdagent","purl":"pkg:rpm/suse/spice-vdagent\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:0372-1"}],"prev":{"headline":"Security feature bypass in dnsmasq","id":"CVE-2017-15107"},"products":["spice-vdagent"],"published":"2018-01-20","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat, Inc."]},"summary":"Local attackers can execute arbitrary commands via improper escaping in the save directory path of the SPICE virtualization agent.","url":"https://insights.sbomify.com/CVE-2017-15108/"}