CVE-2017-15110 Moodle Exposure of Sensitive Information to an Unauthorized Actor
Students can enumerate other students' email addresses via the Participants page search, bypassing visibility settings.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-15110?
CVE-2017-15110 is a medium-severity vulnerability in Moodle Moodle, published on 20 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle 3.x, students can find out email addresses of other students in the same course. Using search on the Participants page, students could search email addresses of all participants regardless of email visibility. This allows enumerating and guessing emails of other students.
Weakness: CWE-200
Which versions are affected by CVE-2017-15110?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.9 |
moodle/moodle Packagist | From 3.1 | 3.1.9 |
moodle/moodle Packagist | From 3.2 | 3.2.6 |
moodle/moodle Packagist | From 3.2 | 3.2.6 |
moodle/moodle Packagist | From 3.3 | 3.3.3 |
moodle/moodle Packagist | From 3.3 | 3.3.3 |
Products include Moodle Moodle.
How do I fix CVE-2017-15110?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.9, 3.2.6 or 3.3.3.
Is CVE-2017-15110 being exploited?
There is no known exploitation of CVE-2017-15110 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-rjh8-w8jg-xwq5.