{"answers":{"affected":"3 open source packages ship an affected version, including keycloak-httpd-client-install. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15111 in the wild and no public exploit code.","fix":"Upgrade keycloak-httpd-client-install to 0.8 or later.","what":"CVE-2017-15111 is a medium-severity path traversal vulnerability in jdennis keycloak-httpd-client-install, published on 20 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15111 and fix it if it is affected.\n\nWhat it is: CVE-2017-15111 is a medium-severity path traversal vulnerability in jdennis keycloak-httpd-client-install, published on 20 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- keycloak-httpd-client-install (PyPI): affected all versions; fixed in 0.8\n- keycloak-httpd-client-install (PyPI): affected all versions; fixed in 0.8\n- keycloak-httpd-client-install (PyPI): affected all versions; fixed in 0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15111/ (Markdown: https://insights.sbomify.com/CVE-2017-15111/index.md)","id":"CVE-2017-15111","markdown":"https://insights.sbomify.com/CVE-2017-15111/index.md","name":"CVE-2017-15111","record":{"aliases":["GHSA-vqf9-v3hc-wr54","PYSEC-2026-829"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Keycloak client installer","requires_auth":"low_privilege","summary":"Local attackers can overwrite arbitrary files via symbolic link attacks due to insecure temporary file creation in the Keycloak HTTPD client installer.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"keycloak-httpd-client-install","vendor":"keycloak-httpd-client-install_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"},{"id":"CWE-377","name":"DEPRECATED: Insecure Temporary File"}],"description":"keycloak-httpd-client-install versions before 0.8 insecurely creates temporary file allowing local attackers to overwrite other files via symbolic link.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"keycloak-httpd-client-install symlink attack vulnerability","id":"CVE-2017-15111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2017"},"n_packages":3,"n_references":2,"next":{"headline":"keycloak-httpd-client-install Insecure Secrets","id":"CVE-2017-15112"},"packages":[{"ecosystem":"PyPI","fixed":["0.8"],"introduced":["0"],"last_affected":[],"package":"keycloak-httpd-client-install","purl":null,"source":"GHSA-vqf9-v3hc-wr54"},{"ecosystem":"PyPI","fixed":["0.8"],"introduced":["0"],"last_affected":[],"package":"keycloak-httpd-client-install","purl":"pkg:pypi/keycloak-httpd-client-install","source":"GHSA-vqf9-v3hc-wr54"},{"ecosystem":"PyPI","fixed":["0.8"],"introduced":["0"],"last_affected":[],"package":"keycloak-httpd-client-install","purl":"pkg:pypi/keycloak-httpd-client-install","source":"PYSEC-2026-829"}],"prev":{"headline":"Moodle Exposure of Sensitive Information to an Unauthorized Actor","id":"CVE-2017-15110"},"products":["keycloak-httpd-client-install"],"published":"2018-01-20","related":[{"cvss_score":7.8,"headline":"keycloak-httpd-client-install Insecure Secrets","id":"CVE-2017-15112","kev_date_added":null,"published":"2018-01-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["jdennis"]},"summary":"Local attackers can overwrite arbitrary files via symbolic link attacks due to insecure temporary file creation in the Keycloak HTTPD client installer.","url":"https://insights.sbomify.com/CVE-2017-15111/"}