CVE-2017-15288 High severity vulnerability that affects org.scala-lang:scala-compiler
Local attackers can exploit weak file permissions in the Scala compilation daemon to overwrite class files and gain elevated privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-15288?
CVE-2017-15288 is a high-severity vulnerability in n/a, published on 15 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The compilation daemon in Scala before 2.10.7, 2.11.x before 2.11.12, and 2.12.x before 2.12.4 uses weak permissions for private files in /tmp/scala-devel/${USER:shared}/scalac-compile-server-port, which allows local users to write to arbitrary class files and consequently gain privileges.
Weakness: CWE-732
Which versions are affected by CVE-2017-15288?
6 open source packages ship an affected version, including org.scala-lang:scala-compiler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.scala-lang:scala-compiler Maven | All versions | 2.10.7 |
org.scala-lang:scala-compiler Maven | All versions | 2.10.7 |
org.scala-lang:scala-compiler Maven | From 2.11.0 | 2.11.12 |
org.scala-lang:scala-compiler Maven | From 2.11.0 | 2.11.12 |
org.scala-lang:scala-compiler Maven | From 2.12.0 | 2.12.4 |
org.scala-lang:scala-compiler Maven | From 2.12.0 | 2.12.4 |
Products include Scala-Lang Scala.
How do I fix CVE-2017-15288?
Upgrade org.scala-lang:scala-compiler to a fixed version for your release line: 2.10.7, 2.11.12 or 2.12.4.
Is CVE-2017-15288 being exploited?
There is no known exploitation of CVE-2017-15288 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2017-15288, GHSA-qvxv-pmq9-4q7g, UBUNTU-CVE-2017-15288.