# CVE-2017-15288: High severity vulnerability that affects org.scala-lang:scala-compiler

> Local attackers can exploit weak file permissions in the Scala compilation daemon to overwrite class files and gain elevated privileges.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-15288, GHSA-qvxv-pmq9-4q7g, UBUNTU-CVE-2017-15288

## What is CVE-2017-15288?

CVE-2017-15288 is a high-severity vulnerability in n/a, published on 15 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The compilation daemon in Scala before 2.10.7, 2.11.x before 2.11.12, and 2.12.x before 2.12.4 uses weak permissions for private files in /tmp/scala-devel/${USER:shared}/scalac-compile-server-port, which allows local users to write to arbitrary class files and consequently gain privileges.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2017-15288?

6 open source packages ship an affected version, including org.scala-lang:scala-compiler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.scala-lang:scala-compiler` | Maven | All versions | 2.10.7 |
| `org.scala-lang:scala-compiler` | Maven | All versions | 2.10.7 |
| `org.scala-lang:scala-compiler` | Maven | From 2.11.0 | 2.11.12 |
| `org.scala-lang:scala-compiler` | Maven | From 2.11.0 | 2.11.12 |
| `org.scala-lang:scala-compiler` | Maven | From 2.12.0 | 2.12.4 |
| `org.scala-lang:scala-compiler` | Maven | From 2.12.0 | 2.12.4 |

Products: Scala-Lang Scala.

## How do I fix CVE-2017-15288?

Upgrade org.scala-lang:scala-compiler to a fixed version for your release line: 2.10.7, 2.11.12 or 2.12.4.

## Is CVE-2017-15288 being exploited?

There is no known exploitation of CVE-2017-15288 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15288 and fix it if it is affected.

What it is: CVE-2017-15288 is a high-severity vulnerability in n/a, published on 15 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15288 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.scala-lang:scala-compiler (Maven): affected all versions; fixed in 2.10.7
- org.scala-lang:scala-compiler (Maven): affected all versions; fixed in 2.10.7
- org.scala-lang:scala-compiler (Maven): affected from 2.11.0; fixed in 2.11.12
- org.scala-lang:scala-compiler (Maven): affected from 2.11.0; fixed in 2.11.12
- org.scala-lang:scala-compiler (Maven): affected from 2.12.0; fixed in 2.12.4
- org.scala-lang:scala-compiler (Maven): affected from 2.12.0; fixed in 2.12.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15288/ (Markdown: https://insights.sbomify.com/CVE-2017-15288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15288
- OSV: https://osv.dev/vulnerability/CVE-2017-15288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15288/
Summaries are generated and may contain mistakes; the official description above is the record.
