{"answers":{"affected":"4 open source packages ship an affected version, including aoe/restler and luracast/restler. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-15363 exists.","fix":"Upgrade aoe/restler to 1.7.1 or later.","what":"CVE-2017-15363 is a high-severity path traversal vulnerability in n/a, published on 15 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15363 and fix it if it is affected.\n\nWhat it is: CVE-2017-15363 is a high-severity path traversal vulnerability in n/a, published on 15 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-15363 exists.\n\nAffected packages and fixed versions:\n- aoe/restler (Packagist): affected all versions; fixed in 1.7.1\n- aoe/restler (Packagist): affected all versions; fixed in 1.7.1\n- luracast/restler (Packagist): affected all versions; fixed in 3.1.0\n- luracast/restler (Packagist): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15363/ (Markdown: https://insights.sbomify.com/CVE-2017-15363/index.md)","id":"CVE-2017-15363","markdown":"https://insights.sbomify.com/CVE-2017-15363/index.md","name":"CVE-2017-15363","record":{"aliases":["GHSA-rvmg-xc29-rvxf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP REST API library","requires_auth":"none","summary":"Remote attackers can read arbitrary files via a directory traversal flaw in the getsource.php script of the Luracast Restler library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"restler","vendor":"luracast"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in public/examples/resources/getsource.php in Luracast Restler through 3.0.0, as used in the restler extension before 1.7.1 for TYPO3, allows remote attackers to read arbitrary files via the file parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2017/CVE-2017-15363.yaml","stars":null,"title":"Luracast Restler 3.0.1 via TYPO3 Restler 1.7.1 - Local File Inclusion"}],"tier":"weaponised"},"has_fix":true,"headline":"Luracast Restler directory traversal vulnerability","id":"CVE-2017-15363","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2017"},"n_packages":4,"n_references":2,"next":{"headline":"ccsv Double Free vulnerability","id":"CVE-2017-15364"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"aoe/restler","purl":null,"source":"GHSA-rvmg-xc29-rvxf"},{"ecosystem":"Packagist","fixed":["1.7.1"],"introduced":["0"],"last_affected":[],"package":"aoe/restler","purl":"pkg:composer/aoe/restler","source":"GHSA-rvmg-xc29-rvxf"},{"ecosystem":"Packagist","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"luracast/restler","purl":null,"source":"GHSA-rvmg-xc29-rvxf"},{"ecosystem":"Packagist","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"luracast/restler","purl":"pkg:composer/luracast/restler","source":"GHSA-rvmg-xc29-rvxf"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-15362"},"products":["n/a"],"published":"2017-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files via a directory traversal flaw in the getsource.php script of the Luracast Restler library.","url":"https://insights.sbomify.com/CVE-2017-15363/"}