# CVE-2017-15363: Luracast Restler directory traversal vulnerability

> Remote attackers can read arbitrary files via a directory traversal flaw in the getsource.php script of the Luracast Restler library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rvmg-xc29-rvxf

## What is CVE-2017-15363?

CVE-2017-15363 is a high-severity path traversal vulnerability in n/a, published on 15 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in public/examples/resources/getsource.php in Luracast Restler through 3.0.0, as used in the restler extension before 1.7.1 for TYPO3, allows remote attackers to read arbitrary files via the file parameter.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-15363?

4 open source packages ship an affected version, including aoe/restler and luracast/restler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aoe/restler` | Packagist | All versions | 1.7.1 |
| `aoe/restler` | Packagist | All versions | 1.7.1 |
| `luracast/restler` | Packagist | All versions | 3.1.0 |
| `luracast/restler` | Packagist | All versions | 3.1.0 |

Products: Luracast Restler.

## How do I fix CVE-2017-15363?

Upgrade aoe/restler to 1.7.1 or later.

## Is CVE-2017-15363 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-15363 exists.

Public exploit code:

- Luracast Restler 3.0.1 via TYPO3 Restler 1.7.1 - Local File Inclusion (nuclei): http/cves/2017/CVE-2017-15363.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15363 and fix it if it is affected.

What it is: CVE-2017-15363 is a high-severity path traversal vulnerability in n/a, published on 15 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-15363 exists.

Affected packages and fixed versions:
- aoe/restler (Packagist): affected all versions; fixed in 1.7.1
- aoe/restler (Packagist): affected all versions; fixed in 1.7.1
- luracast/restler (Packagist): affected all versions; fixed in 3.1.0
- luracast/restler (Packagist): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15363/ (Markdown: https://insights.sbomify.com/CVE-2017-15363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15363
- OSV: https://osv.dev/vulnerability/CVE-2017-15363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15363/
Summaries are generated and may contain mistakes; the official description above is the record.
