{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15374 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-15374 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-15374 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 16 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-15374 and fix it if it is affected.\n\nWhat it is: CVE-2017-15374 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 16 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-15374 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected from 5.2.5 up to 5.3; no fix listed\n- shopware/shopware (Packagist): affected from 5.2.5 up to 5.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15374/ (Markdown: https://insights.sbomify.com/CVE-2017-15374/index.md)","id":"CVE-2017-15374","markdown":"https://insights.sbomify.com/CVE-2017-15374/index.md","name":"CVE-2017-15374","record":{"aliases":["GHSA-mvrx-cmqw-2jgj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"none","summary":"Remote attackers can inject malicious scripts into customer or order fields, leading to persistent XSS and potential admin account takeover in Shopware.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"shopware","vendor":"shopware"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Shopware v5.2.5 - v5.3 is vulnerable to cross site scripting in the customer and order section of the content management system backend modules. Remote attackers are able to inject malicious script code into the firstname, lastname, or order input fields to provoke persistent execution in the customer and orders section of the backend. The execution occurs in the administrator backend listing when processing a preview of the customers (kunden) or orders (bestellungen). The injection can be performed interactively via user registration or by manipulation of the order information inputs. The issue can be exploited by low privileged user accounts against higher privileged (admin or moderator) accounts.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2018-01-21","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-01-21","kind":"exploitdb","ref":"43849","stars":null,"title":"Shopware 5.2.5/5.3 - Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":false,"headline":"Shopware XSS Vulnerability","id":"CVE-2017-15374","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"shopware:shopware","products":["shopware:shopware"],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-15375"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["5.2.5"],"last_affected":["5.3"],"package":"shopware/shopware","purl":null,"source":"GHSA-mvrx-cmqw-2jgj"},{"ecosystem":"Packagist","fixed":[],"introduced":["5.2.5"],"last_affected":["5.3"],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-mvrx-cmqw-2jgj"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2017-15373"},"products":["n/a"],"published":"2017-10-16","related":[{"cvss_score":10,"headline":"Improper Control of Generation of Code in Twig rendered views in shopware","id":"CVE-2023-22731","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Shopware RCE Vulnerability","id":"CVE-2016-3109","kev_date_added":null,"published":"2017-04-21"},{"cvss_score":9.3,"headline":"Blind SQL-injection in DAL aggregations in Shopware","id":"CVE-2024-22406","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":9.1,"headline":"Leak of information via Store-API","id":"CVE-2021-32711","kev_date_added":null,"published":"2021-06-24"},{"cvss_score":8.9,"headline":"Shopware unauthenticated data extraction possible through store-api.order endpoint","id":"CVE-2026-31887","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.9,"headline":"Shopware has a potential take over of app credentials","id":"CVE-2026-31889","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.8,"headline":"Improper Control of Generation of Code in Twig Rendered Views in Shopware","id":"CVE-2023-2017","kev_date_added":null,"published":"2023-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts into customer or order fields, leading to persistent XSS and potential admin account takeover in Shopware.","url":"https://insights.sbomify.com/CVE-2017-15374/"}