# CVE-2017-15412: Nokogiri gem, via libxml, is affected by DoS vulnerabilities

> A remote attacker can exploit heap corruption via a crafted HTML page to potentially execute arbitrary code in Google Chrome.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-15412, DLA-1211-1, DSA-4086-1, ECHO-5578-a69b-6ed0, GHSA-r58r-74gx-6wx3, UBUNTU-CVE-2017-15412, USN-3513-1

## What is CVE-2017-15412?

CVE-2017-15412 is a high-severity use after free vulnerability in Debian Debian Linux, published on 28 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2017-15412?

2 open source packages ship an affected version, including nokogiri. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.8.2 |
| `nokogiri` | RubyGems | All versions | 1.8.2 |

Products: Debian Debian Linux, Google Chrome, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Workstation, Xmlsoft Libxml2.

## How do I fix CVE-2017-15412?

Upgrade nokogiri to 1.8.2 or later.

## Is CVE-2017-15412 being exploited?

There is no known exploitation of CVE-2017-15412 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15412 and fix it if it is affected.

What it is: CVE-2017-15412 is a high-severity use after free vulnerability in Debian Debian Linux, published on 28 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-15412 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.8.2
- nokogiri (RubyGems): affected all versions; fixed in 1.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15412/ (Markdown: https://insights.sbomify.com/CVE-2017-15412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15412
- OSV: https://osv.dev/vulnerability/CVE-2017-15412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15412/
Summaries are generated and may contain mistakes; the official description above is the record.
