{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2017-15429 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-15429 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-15429 and fix it if it is affected.\n\nWhat it is: CVE-2017-15429 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-15429 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15429/ (Markdown: https://insights.sbomify.com/CVE-2017-15429/index.md)","id":"CVE-2017-15429","markdown":"https://insights.sbomify.com/CVE-2017-15429/index.md","name":"CVE-2017-15429","record":{"aliases":["GHSA-cqrg-9hh6-w946","RHSA-2017:3479","UBUNTU-CVE-2017-15429","openSUSE-SU-2017:3344-1","openSUSE-SU-2017:3346-1"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Google Chrome","requires_auth":"none","summary":"Remote attackers can inject arbitrary scripts or HTML via crafted pages due to V8 WebAssembly implementation flaws in Google Chrome.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Chrome","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"chrome","vendor":"google"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Inappropriate implementation in V8 WebAssembly JS bindings in Google Chrome prior to 63.0.3239.108 allowed a remote attacker to inject arbitrary scripts or HTML (UXSS) via a crafted HTML page.","ecosystems":["Red Hat:rhel_extras:6","SUSE:Package Hub 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in Google Chrome prior to 63.0.3239.108 unknown","id":"CVE-2017-15429","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","google:chrome","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"xss","year":"2017"},"n_packages":4,"n_references":6,"next":{"headline":"Cross-site scripting in Chrome","id":"CVE-2017-15430"},"packages":[{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:63.0.3239.108-1.el6_9"],"introduced":["0"],"last_affected":[],"package":"chromium-browser","purl":"pkg:rpm/redhat/chromium-browser","source":"RHSA-2017:3479"},{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:63.0.3239.108-1.el6_9"],"introduced":["0"],"last_affected":[],"package":"chromium-browser-debuginfo","purl":"pkg:rpm/redhat/chromium-browser-debuginfo","source":"RHSA-2017:3479"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["63.0.3239.108-43.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/suse/chromium\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:3344-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["63.0.3239.108-43.1"],"introduced":["0"],"last_affected":[],"package":"chromium","purl":"pkg:rpm/suse/chromium\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:3346-1"}],"prev":{"headline":"Memory corruption in Chrome","id":"CVE-2017-15428"},"products":["Google Chrome prior to 63.0.3239.108 unknown"],"published":"2018-08-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary scripts or HTML via crafted pages due to V8 WebAssembly implementation flaws in Google Chrome.","url":"https://insights.sbomify.com/CVE-2017-15429/"}