CVE-2017-15519 Auth bypass in SnapCenter

High 7.2 Published Updated

Unauthenticated attackers can view and modify backup data in SnapCenter via the NAS File Services plug-in, requiring an upgrade to secure the system.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2017-15519?

CVE-2017-15519 is a high-severity authentication bypass vulnerability in NetApp SnapCenter, published on 6 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of SnapCenter 2.0 through 3.0.1 allow unauthenticated remote attackers to view and modify backup related data via the Plug-in for NAS File Services. All users are urged to move to version 3.0.1 and perform the mitigation steps or upgrade to 4.0 following the product documentation.

Weakness: CWE-287

Which versions are affected by CVE-2017-15519?

It affects 1 product.

Products include Netapp Snapcenter Server.

How do I fix CVE-2017-15519?

No fix has been published for CVE-2017-15519 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2017-15519 being exploited?

There is no known exploitation of CVE-2017-15519 in the wild and no public exploit code.

Sources

Also known as GHSA-9393-ff8q-r5g5.

Is CVE-2017-15519 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free