{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15519 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-15519 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-15519 is a high-severity authentication bypass vulnerability in NetApp SnapCenter, published on 6 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15519 and fix it if it is affected.\n\nWhat it is: CVE-2017-15519 is a high-severity authentication bypass vulnerability in NetApp SnapCenter, published on 6 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15519 in the wild and no public exploit code.\n\nAffected product: NetApp SnapCenter. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15519/ (Markdown: https://insights.sbomify.com/CVE-2017-15519/index.md)","id":"CVE-2017-15519","markdown":"https://insights.sbomify.com/CVE-2017-15519/index.md","name":"CVE-2017-15519","record":{"aliases":["GHSA-9393-ff8q-r5g5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"NetApp SnapCenter","requires_auth":"none","summary":"Unauthenticated attackers can view and modify backup data in SnapCenter via the NAS File Services plug-in, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"netapp","cpe":[{"product":"snapcenter_server","vendor":"netapp"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Versions of SnapCenter 2.0 through 3.0.1 allow unauthenticated remote attackers to view and modify backup related data via the Plug-in for NAS File Services. All users are urged to move to version 3.0.1 and perform the mitigation steps or upgrade to 4.0 following the product documentation.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Auth bypass in SnapCenter","id":"CVE-2017-15519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":0,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-15520"},"packages":[],"prev":{"headline":"Information disclosure in OnCommand API Services and NetApp Service Level Manager","id":"CVE-2017-15518"},"products":["SnapCenter"],"published":"2018-03-06","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in SnapCenter Server","id":"CVE-2017-15516","kev_date_added":null,"published":"2017-11-16"},{"cvss_score":8.1,"headline":"Missing authorization in n/a","id":"CVE-2015-7887","kev_date_added":null,"published":"2017-08-07"},{"cvss_score":7.3,"headline":"Auth bypass in n/a","id":"CVE-2016-1502","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":5.3,"headline":"Information disclosure in SnapCenter Server","id":"CVE-2018-5482","kev_date_added":null,"published":"2019-03-04"},{"cvss_score":4.8,"headline":"Cross-site scripting in SnapCenter Server","id":"CVE-2017-15515","kev_date_added":null,"published":"2019-03-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["NetApp"]},"summary":"Unauthenticated attackers can view and modify backup data in SnapCenter via the NAS File Services plug-in, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2017-15519/"}