# CVE-2017-15519: Auth bypass in SnapCenter

> Unauthenticated attackers can view and modify backup data in SnapCenter via the NAS File Services plug-in, requiring an upgrade to secure the system.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-9393-ff8q-r5g5

## What is CVE-2017-15519?

CVE-2017-15519 is a high-severity authentication bypass vulnerability in NetApp SnapCenter, published on 6 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of SnapCenter 2.0 through 3.0.1 allow unauthenticated remote attackers to view and modify backup related data via the Plug-in for NAS File Services. All users are urged to move to version 3.0.1 and perform the mitigation steps or upgrade to 4.0 following the product documentation.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-15519?

It affects 1 product.


Products: Netapp Snapcenter Server.

## How do I fix CVE-2017-15519?

No fix has been published for CVE-2017-15519 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-15519 being exploited?

There is no known exploitation of CVE-2017-15519 in the wild and no public exploit code.

## Other vulnerabilities in NetApp SnapCenter

- [CVE-2017-15516](https://insights.sbomify.com/CVE-2017-15516/): Cross-site request forgery in SnapCenter Server (high 8.8)
- [CVE-2015-7887](https://insights.sbomify.com/CVE-2015-7887/): Missing authorization in n/a (high 8.1)
- [CVE-2016-1502](https://insights.sbomify.com/CVE-2016-1502/): Auth bypass in n/a (high 7.3)
- [CVE-2018-5482](https://insights.sbomify.com/CVE-2018-5482/): Information disclosure in SnapCenter Server (medium 5.3)
- [CVE-2017-15515](https://insights.sbomify.com/CVE-2017-15515/): Cross-site scripting in SnapCenter Server (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15519 and fix it if it is affected.

What it is: CVE-2017-15519 is a high-severity authentication bypass vulnerability in NetApp SnapCenter, published on 6 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15519 in the wild and no public exploit code.

Affected product: NetApp SnapCenter. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15519/ (Markdown: https://insights.sbomify.com/CVE-2017-15519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15519
- OSV: https://osv.dev/vulnerability/CVE-2017-15519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15519/
Summaries are generated and may contain mistakes; the official description above is the record.
