{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15535 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-15535 is a critical denial of service vulnerability in Mongodb Mongodb, published on 1 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15535 and fix it if it is affected.\n\nWhat it is: CVE-2017-15535 is a critical denial of service vulnerability in Mongodb Mongodb, published on 1 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15535 in the wild and no public exploit code.\n\nAffected product: Mongodb Mongodb. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15535/ (Markdown: https://insights.sbomify.com/CVE-2017-15535/index.md)","id":"CVE-2017-15535","markdown":"https://insights.sbomify.com/CVE-2017-15535/index.md","name":"CVE-2017-15535","record":{"aliases":["GHSA-pm5g-pw4v-3mv8","openSUSE-SU-2017:3018-1","openSUSE-SU-2017:3022-1"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"MongoDB database","requires_auth":"none","summary":"A malicious attacker can cause denial of service or modify memory in MongoDB when the disabled-by-default wire protocol compression feature is enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mongodb","vendor":"mongodb"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[],"description":"MongoDB 3.4.x before 3.4.10, and 3.5.x-development, has a disabled-by-default configuration setting, networkMessageCompressors (aka wire protocol compression), which exposes a vulnerability when enabled that could be exploited by a malicious attacker to deny service or modify memory.","ecosystems":["SUSE:Package Hub 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2017-15535","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"mongodb:mongodb","products":["mongodb:mongodb"],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2017-15536"},"packages":[{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["3.4.10-5.1"],"introduced":["0"],"last_affected":[],"package":"mongodb","purl":"pkg:rpm/suse/mongodb\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:3018-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["3.4.10-5.1"],"introduced":["0"],"last_affected":[],"package":"mongodb","purl":"pkg:rpm/suse/mongodb\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:3022-1"}],"prev":{"headline":"Auth bypass in Norton App Lock","id":"CVE-2017-15534"},"products":["n/a"],"published":"2017-11-01","related":[{"cvss_score":8.7,"headline":"MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency","id":"CVE-2025-14847","kev_date_added":"2025-12-29","published":"2025-12-19"},{"cvss_score":9.2,"headline":"Auth bypass in MongoDB Server","id":"CVE-2026-82067","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption","id":"CVE-2026-13072","kev_date_added":null,"published":"2026-07-22"},{"cvss_score":9,"headline":"Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure","id":"CVE-2026-18691","kev_date_added":null,"published":"2026-08-11"},{"cvss_score":8.8,"headline":"MongoDB Server may allow successful untrusted connection","id":"CVE-2024-1351","kev_date_added":null,"published":"2024-03-07"},{"cvss_score":8.7,"headline":"Denial of service in MongoDB Server","id":"CVE-2026-82064","kev_date_added":null,"published":"2026-09-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A malicious attacker can cause denial of service or modify memory in MongoDB when the disabled-by-default wire protocol compression feature is enabled.","url":"https://insights.sbomify.com/CVE-2017-15535/"}