{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15566 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-15566 is a high-severity vulnerability in n/a, published on 1 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15566 and fix it if it is affected.\n\nWhat it is: CVE-2017-15566 is a high-severity vulnerability in n/a, published on 1 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15566 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15566/ (Markdown: https://insights.sbomify.com/CVE-2017-15566/index.md)","id":"CVE-2017-15566","markdown":"https://insights.sbomify.com/CVE-2017-15566/index.md","name":"CVE-2017-15566","record":{"aliases":["DSA-4023-1","GHSA-h3p2-v728-89g5","SUSE-SU-2017:3311-1","UBUNTU-CVE-2017-15566"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Slurm workload manager","requires_auth":"low_privilege","summary":"Attackers can escalate privileges to root via insecure environment variable handling in Slurm during Prolog or Epilog execution.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"slurm","vendor":"schedmd"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"Insecure SPANK environment variable handling exists in SchedMD Slurm before 16.05.11, 17.x before 17.02.9, and 17.11.x before 17.11.0rc2, allowing privilege escalation to root during Prolog or Epilog execution.","ecosystems":["SUSE:Linux Enterprise Module for HPC 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in n/a","id":"CVE-2017-15566","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2017-15567"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for HPC 12","fixed":["2.33-7.5.17"],"introduced":["0"],"last_affected":[],"package":"pdsh","purl":"pkg:rpm/suse/pdsh\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2012","source":"SUSE-SU-2017:3311-1"},{"ecosystem":"SUSE:Linux Enterprise Module for HPC 12","fixed":["17.02.9-6.10.1"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/suse/slurm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2012","source":"SUSE-SU-2017:3311-1"},{"ecosystem":"SUSE:Linux Enterprise Module for HPC 12","fixed":["16.05.8.1-6.1"],"introduced":["0"],"last_affected":[],"package":"slurmlibs","purl":"pkg:rpm/suse/slurmlibs\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2012","source":"SUSE-SU-2017:3311-1"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2017-15565"},"products":["n/a"],"published":"2017-11-01","related":[{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2023-49934","kev_date_added":null,"published":"2023-12-14"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2023-49937","kev_date_added":null,"published":"2023-12-14"},{"cvss_score":8.8,"headline":"Auth bypass in n/a","id":"CVE-2023-49935","kev_date_added":null,"published":"2023-12-14"},{"cvss_score":8.2,"headline":"Privilege escalation in n/a","id":"CVE-2023-49938","kev_date_added":null,"published":"2023-12-14"},{"cvss_score":8.1,"headline":"Path traversal in n/a","id":"CVE-2016-10030","kev_date_added":null,"published":"2017-01-05"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2023-49933","kev_date_added":null,"published":"2023-12-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can escalate privileges to root via insecure environment variable handling in Slurm during Prolog or Epilog execution.","url":"https://insights.sbomify.com/CVE-2017-15566/"}