CVE-2017-15655 Memory corruption in n/a

Critical 9.6 Published Updated

Buffer overflows in Asus router HTTPd allow remote code execution with admin rights when an administrator visits specific pages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-15655?

CVE-2017-15655 is a critical memory corruption vulnerability in n/a, published on 31 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.

Weakness: CWE-119

Which versions are affected by CVE-2017-15655?

It affects 1 product.

Products include Asus Asuswrt.

How do I fix CVE-2017-15655?

No fix has been published for CVE-2017-15655 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2017-15655 being exploited?

There is no known exploitation of CVE-2017-15655 in the wild and no public exploit code.

Sources

Also known as GHSA-w6cp-hqm8-4phj.

Is CVE-2017-15655 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free