# CVE-2017-15655: Memory corruption in n/a

> Buffer overflows in Asus router HTTPd allow remote code execution with admin rights when an administrator visits specific pages.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w6cp-hqm8-4phj

## What is CVE-2017-15655?

CVE-2017-15655 is a critical memory corruption vulnerability in n/a, published on 31 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2017-15655?

It affects 1 product.


Products: Asus Asuswrt.

## How do I fix CVE-2017-15655?

No fix has been published for CVE-2017-15655 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-15655 being exploited?

There is no known exploitation of CVE-2017-15655 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-20334](https://insights.sbomify.com/CVE-2018-20334/): Command injection in n/a (critical 9.8)
- [CVE-2018-5999](https://insights.sbomify.com/CVE-2018-5999/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-6000](https://insights.sbomify.com/CVE-2018-6000/): Missing authorization in n/a (critical 9.8)
- [CVE-2017-15653](https://insights.sbomify.com/CVE-2017-15653/): Auth bypass in n/a (high 8.8)
- [CVE-2017-15656](https://insights.sbomify.com/CVE-2017-15656/): Hardcoded credentials in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15655 and fix it if it is affected.

What it is: CVE-2017-15655 is a critical memory corruption vulnerability in n/a, published on 31 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-15655 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15655/ (Markdown: https://insights.sbomify.com/CVE-2017-15655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15655
- OSV: https://osv.dev/vulnerability/CVE-2017-15655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15655/
Summaries are generated and may contain mistakes; the official description above is the record.
