# CVE-2017-15680: Missing Authorization in Crafter CMS

> Unauthenticated attackers can view and modify administrative data in Crafter Studio due to missing authorization checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2020
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-2rr8-9c6g-8j5c

## What is CVE-2017-15680?

CVE-2017-15680 is a medium-severity missing authorization vulnerability in n/a, published on 27 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Crafter CMS Crafter Studio 3.0.1 an IDOR vulnerability exists which allows unauthenticated attackers to view and modify administrative data.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-15680?

2 open source packages ship an affected version, including org.craftercms:crafter-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.craftercms:crafter-core` | Maven | From 3.0.0 | 3.0.1 |
| `org.craftercms:crafter-core` | Maven | From 3.0.0 | 3.0.1 |

Products: Craftercms Crafter Cms.

## How do I fix CVE-2017-15680?

Upgrade org.craftercms:crafter-core to 3.0.1 or later.

## Is CVE-2017-15680 being exploited?

There is no known exploitation of CVE-2017-15680 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-15681](https://insights.sbomify.com/CVE-2017-15681/): Path Traversal in Crafter CMS Crafter Studio (critical 9.8)
- [CVE-2018-19907](https://insights.sbomify.com/CVE-2018-19907/): OS Command Injection in craftercms:crafter-studio (high 8.8)
- [CVE-2017-15683](https://insights.sbomify.com/CVE-2017-15683/): XML injection in Crafter CMS (high 8.6)
- [CVE-2017-15685](https://insights.sbomify.com/CVE-2017-15685/): XML Injection in Crafter CMS Crafter Studio 3.0.1 (high 8.6)
- [CVE-2021-23264](https://insights.sbomify.com/CVE-2021-23264/): Exposure of Resource to Wrong Sphere in org.craftercms:crafter-search (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15680 and fix it if it is affected.

What it is: CVE-2017-15680 is a medium-severity missing authorization vulnerability in n/a, published on 27 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15680 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.craftercms:crafter-core (Maven): affected from 3.0.0; fixed in 3.0.1
- org.craftercms:crafter-core (Maven): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15680/ (Markdown: https://insights.sbomify.com/CVE-2017-15680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15680
- OSV: https://osv.dev/vulnerability/CVE-2017-15680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15680/
Summaries are generated and may contain mistakes; the official description above is the record.
