CVE-2017-15686 Cross-site scripting in Crafter CMS Crafter Studio

Medium 6.1 Published Updated

Remote attackers can execute arbitrary scripts in Crafter Studio to steal user cookies, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-15686?

CVE-2017-15686 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Crafter CMS Crafter Studio 3.0.1 is affected by: Cross Site Scripting (XSS), which allows remote attackers to steal users’ cookies.

Weakness: CWE-79

Which versions are affected by CVE-2017-15686?

2 open source packages ship an affected version, including org.craftercms:crafter-studio. It affects 1 product.

PackageAffectedFixed in
org.craftercms:crafter-studio MavenAll versions3.0.2
org.craftercms:crafter-studio MavenAll versions3.0.2

Products include Craftercms Crafter Cms.

How do I fix CVE-2017-15686?

Upgrade org.craftercms:crafter-studio to 3.0.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-15686 being exploited?

There is no known exploitation of CVE-2017-15686 in the wild and no public exploit code.

Sources

Also known as GHSA-ph76-rhqq-xj7j.

Is CVE-2017-15686 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free