CVE-2017-15691 Improper Restriction of XML External Entity Reference in Apache uimaj
An attacker can exploit XML external entity expansion in Apache UIMA to disclose local files or internal content.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-15691?
CVE-2017-15691 is a medium-severity vulnerability in Apache UIMA, published on 26 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Apache uimaj prior to 2.10.2, Apache uimaj 3.0.0-xxx prior to 3.0.0-beta, Apache uima-as prior to 2.10.2, Apache uimaFIT prior to 2.4.0, Apache uimaDUCC prior to 2.2.2, this vulnerability relates to an XML external entity expansion (XXE) capability of various XML parsers. UIMA as part of its configuration and operation may read XML from various sources, which could be tainted in ways to cause inadvertent disclosure of local files or other internal content.
Weakness: CWE-611
Which versions are affected by CVE-2017-15691?
8 open source packages ship an affected version, including org.apache.uima:uimaj-core, org.apache.uima:uimafit-core and org.apache.uima:uimaj-as-core. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.uima:uimaj-core Maven | All versions | 2.10.2 |
org.apache.uima:uimaj-core Maven | All versions | 2.10.2 |
org.apache.uima:uimaj-core Maven | From 3.0.0-alpha | 3.0.0-beta |
org.apache.uima:uimaj-core Maven | From 3.0.0-alpha | 3.0.0-beta |
org.apache.uima:uimafit-core Maven | All versions | 2.4.0 |
org.apache.uima:uimafit-core Maven | All versions | 2.4.0 |
2 more packages
org.apache.uima:uimaj-as-core Maven | All versions | 2.10.2 |
org.apache.uima:uimaj-as-core Maven | All versions | 2.10.2 |
Products include Apache Uima-As, Apache Uimaducc, Apache Uimafit, Apache Uimaj.
How do I fix CVE-2017-15691?
Upgrade org.apache.uima:uimaj-core to a fixed version for your release line: 2.10.2 or 3.0.0-beta.
Is CVE-2017-15691 being exploited?
There is no known exploitation of CVE-2017-15691 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2017-15691, GHSA-wp2f-hrg2-3r5m, UBUNTU-CVE-2017-15691.