# CVE-2017-15691: Improper Restriction of XML External Entity Reference in Apache uimaj

> An attacker can exploit XML external entity expansion in Apache UIMA to disclose local files or internal content.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-15691, GHSA-wp2f-hrg2-3r5m, UBUNTU-CVE-2017-15691

## What is CVE-2017-15691?

CVE-2017-15691 is a medium-severity vulnerability in Apache UIMA, published on 26 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache uimaj prior to 2.10.2, Apache uimaj 3.0.0-xxx prior to 3.0.0-beta, Apache uima-as prior to 2.10.2, Apache uimaFIT prior to 2.4.0, Apache uimaDUCC prior to 2.2.2, this vulnerability relates to an XML external entity expansion (XXE) capability of various XML parsers. UIMA as part of its configuration and operation may read XML from various sources, which could be tainted in ways to cause inadvertent disclosure of local files or other internal content.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2017-15691?

8 open source packages ship an affected version, including org.apache.uima:uimaj-core, org.apache.uima:uimafit-core and org.apache.uima:uimaj-as-core. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.uima:uimaj-core` | Maven | All versions | 2.10.2 |
| `org.apache.uima:uimaj-core` | Maven | All versions | 2.10.2 |
| `org.apache.uima:uimaj-core` | Maven | From 3.0.0-alpha | 3.0.0-beta |
| `org.apache.uima:uimaj-core` | Maven | From 3.0.0-alpha | 3.0.0-beta |
| `org.apache.uima:uimafit-core` | Maven | All versions | 2.4.0 |
| `org.apache.uima:uimafit-core` | Maven | All versions | 2.4.0 |
| `org.apache.uima:uimaj-as-core` | Maven | All versions | 2.10.2 |
| `org.apache.uima:uimaj-as-core` | Maven | All versions | 2.10.2 |

Products: Apache Uima-As, Apache Uimaducc, Apache Uimafit, Apache Uimaj.

## How do I fix CVE-2017-15691?

Upgrade org.apache.uima:uimaj-core to a fixed version for your release line: 2.10.2 or 3.0.0-beta.

## Is CVE-2017-15691 being exploited?

There is no known exploitation of CVE-2017-15691 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15691 and fix it if it is affected.

What it is: CVE-2017-15691 is a medium-severity vulnerability in Apache UIMA, published on 26 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15691 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.uima:uimaj-core (Maven): affected all versions; fixed in 2.10.2
- org.apache.uima:uimaj-core (Maven): affected all versions; fixed in 2.10.2
- org.apache.uima:uimaj-core (Maven): affected from 3.0.0-alpha; fixed in 3.0.0-beta
- org.apache.uima:uimaj-core (Maven): affected from 3.0.0-alpha; fixed in 3.0.0-beta
- org.apache.uima:uimafit-core (Maven): affected all versions; fixed in 2.4.0
- org.apache.uima:uimafit-core (Maven): affected all versions; fixed in 2.4.0
- org.apache.uima:uimaj-as-core (Maven): affected all versions; fixed in 2.10.2
- org.apache.uima:uimaj-as-core (Maven): affected all versions; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15691/ (Markdown: https://insights.sbomify.com/CVE-2017-15691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15691
- OSV: https://osv.dev/vulnerability/CVE-2017-15691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15691/
Summaries are generated and may contain mistakes; the official description above is the record.
