# CVE-2017-15692: Apache Geode unsafe deserialization in TcpServer

> An unprivileged user can achieve remote code execution by sending malicious serialized data to the Geode locator's network port.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-w395-hpq9-7xwr

## What is CVE-2017-15692?

CVE-2017-15692 is a critical unsafe deserialization vulnerability in Apache Geode, published on 27 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Geode before v1.4.0, the TcpServer within the Geode locator opens a network port that deserializes data. If an unprivileged user gains access to the Geode locator, they may be able to cause remote code execution if certain classes are present on the classpath.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-15692?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geode:geode-core` | Maven | From 1.0.0 | 1.4.0 |
| `org.apache.geode:geode-core` | Maven | From 1.0.0 | 1.4.0 |

Products: Apache Geode.

## How do I fix CVE-2017-15692?

Upgrade org.apache.geode:geode-core to 1.4.0 or later.

## Is CVE-2017-15692 being exploited?

There is no known exploitation of CVE-2017-15692 in the wild and no public exploit code.

## Other vulnerabilities in Apache Geode

- [CVE-2020-1938](https://insights.sbomify.com/CVE-2020-1938/): Apache Tomcat Improper Privilege Management (critical 9.8, exploited in the wild)
- [CVE-2019-15752](https://insights.sbomify.com/CVE-2019-15752/): Docker Desktop Community Edition Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2022-37021](https://insights.sbomify.com/CVE-2022-37021/): Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. (critical 9.8)
- [CVE-2014-0048](https://insights.sbomify.com/CVE-2014-0048/): Supply chain in docker.io (critical 9.8)
- [CVE-2025-47410](https://insights.sbomify.com/CVE-2025-47410/): Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15692 and fix it if it is affected.

What it is: CVE-2017-15692 is a critical unsafe deserialization vulnerability in Apache Geode, published on 27 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15692 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.geode:geode-core (Maven): affected from 1.0.0; fixed in 1.4.0
- org.apache.geode:geode-core (Maven): affected from 1.0.0; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15692/ (Markdown: https://insights.sbomify.com/CVE-2017-15692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15692
- OSV: https://osv.dev/vulnerability/CVE-2017-15692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15692/
Summaries are generated and may contain mistakes; the official description above is the record.
