{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15694 in the wild and no public exploit code.","fix":"Upgrade org.apache.geode:geode-core to 1.9.0 or later.","what":"CVE-2017-15694 is a medium-severity missing authorization vulnerability in Apache Geode, published on 21 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15694 and fix it if it is affected.\n\nWhat it is: CVE-2017-15694 is a medium-severity missing authorization vulnerability in Apache Geode, published on 21 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15694 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.9.0\n- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15694/ (Markdown: https://insights.sbomify.com/CVE-2017-15694/index.md)","id":"CVE-2017-15694","markdown":"https://insights.sbomify.com/CVE-2017-15694/index.md","name":"CVE-2017-15694","record":{"aliases":["GHSA-p426-qw2p-v95v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Geode server","requires_auth":"low_privilege","summary":"A user with write permissions can modify internal cluster metadata in secure mode, potentially disrupting cluster operations.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"geode","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Argument Injection in Apache Geode server","id":"CVE-2017-15694","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Geode vulnerable to Incorrect Authorization","id":"CVE-2017-15695"},"packages":[{"ecosystem":"Maven","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":null,"source":"GHSA-p426-qw2p-v95v"},{"ecosystem":"Maven","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":"pkg:maven/org.apache.geode/geode-core","source":"GHSA-p426-qw2p-v95v"}],"prev":{"headline":"Apache Geode unsafe deserialization of application objects","id":"CVE-2017-15693"},"products":["Apache Geode"],"published":"2019-06-21","related":[{"cvss_score":9.8,"headline":"Apache Tomcat Improper Privilege Management","id":"CVE-2020-1938","kev_date_added":"2022-03-03","published":"2020-02-24"},{"cvss_score":7.8,"headline":"Docker Desktop Community Edition Privilege Escalation","id":"CVE-2019-15752","kev_date_added":"2021-11-03","published":"2019-08-28"},{"cvss_score":9.8,"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.","id":"CVE-2022-37021","kev_date_added":null,"published":"2022-08-31"},{"cvss_score":9.8,"headline":"Supply chain in docker.io","id":"CVE-2014-0048","kev_date_added":null,"published":"2020-01-02"},{"cvss_score":9.8,"headline":"Apache Geode unsafe deserialization in TcpServer","id":"CVE-2017-15692","kev_date_added":null,"published":"2018-02-27"},{"cvss_score":8.8,"headline":"Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system","id":"CVE-2025-47410","kev_date_added":null,"published":"2025-10-18"},{"cvss_score":8.8,"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11","id":"CVE-2022-37022","kev_date_added":null,"published":"2022-08-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A user with write permissions can modify internal cluster metadata in secure mode, potentially disrupting cluster operations.","url":"https://insights.sbomify.com/CVE-2017-15694/"}