# CVE-2017-15695: Apache Geode vulnerable to Incorrect Authorization

> Users with DATA:WRITE privileges can deploy code via internal functions, leading to remote code execution on Apache Geode servers.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jmg4-x4vp-6c6x

## What is CVE-2017-15695?

CVE-2017-15695 is a high-severity missing authorization vulnerability in Apache Geode, published on 13 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to deploy code by invoking an internal Geode function. This allows remote code execution. Code deployment should be restricted to users with DATA:MANAGE privilege.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2017-15695?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geode:geode-core` | Maven | From 1.0.0 | 1.5.0 |
| `org.apache.geode:geode-core` | Maven | From 1.0.0 | 1.5.0 |

Products: Apache Geode.

## How do I fix CVE-2017-15695?

Upgrade org.apache.geode:geode-core to 1.5.0 or later.

## Is CVE-2017-15695 being exploited?

There is no known exploitation of CVE-2017-15695 in the wild and no public exploit code.

## Other vulnerabilities in Apache Geode

- [CVE-2020-1938](https://insights.sbomify.com/CVE-2020-1938/): Apache Tomcat Improper Privilege Management (critical 9.8, exploited in the wild)
- [CVE-2019-15752](https://insights.sbomify.com/CVE-2019-15752/): Docker Desktop Community Edition Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2022-37021](https://insights.sbomify.com/CVE-2022-37021/): Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. (critical 9.8)
- [CVE-2014-0048](https://insights.sbomify.com/CVE-2014-0048/): Supply chain in docker.io (critical 9.8)
- [CVE-2017-15692](https://insights.sbomify.com/CVE-2017-15692/): Apache Geode unsafe deserialization in TcpServer (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15695 and fix it if it is affected.

What it is: CVE-2017-15695 is a high-severity missing authorization vulnerability in Apache Geode, published on 13 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15695 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.geode:geode-core (Maven): affected from 1.0.0; fixed in 1.5.0
- org.apache.geode:geode-core (Maven): affected from 1.0.0; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15695/ (Markdown: https://insights.sbomify.com/CVE-2017-15695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15695
- OSV: https://osv.dev/vulnerability/CVE-2017-15695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15695/
Summaries are generated and may contain mistakes; the official description above is the record.
