{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.auth.core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15700 in the wild and no public exploit code.","fix":"Upgrade org.apache.sling:org.apache.sling.auth.core to 1.4.2 or later.","what":"CVE-2017-15700 is a high-severity vulnerability in Apache Sling, published on 18 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-15700 and fix it if it is affected.\n\nWhat it is: CVE-2017-15700 is a high-severity vulnerability in Apache Sling, published on 18 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-15700 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.sling:org.apache.sling.auth.core (Maven): affected from 1.4.0; fixed in 1.4.2\n- org.apache.sling:org.apache.sling.auth.core (Maven): affected from 1.4.0; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15700/ (Markdown: https://insights.sbomify.com/CVE-2017-15700/index.md)","id":"CVE-2017-15700","markdown":"https://insights.sbomify.com/CVE-2017-15700/index.md","name":"CVE-2017-15700","record":{"aliases":["GHSA-vcvp-89fq-hwj8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Sling","requires_auth":"none","summary":"Attackers can trick victims into sending credentials via the Sling login form, leading to account takeover.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"sling_authentication_service","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A flaw in the org.apache.sling.auth.core.AuthUtil#isRedirectValid method in Apache Sling Authentication Service 1.4.0 allows an attacker, through the Sling login form, to trick a victim to send over their credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Sling Authentication Service vulnerability","id":"CVE-2017-15700","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"open_redirect","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Qpid Broker-J vulnerable to Denial of Service (DoS) via uncontrolled resource consumption","id":"CVE-2017-15701"},"packages":[{"ecosystem":"Maven","fixed":["1.4.2"],"introduced":["1.4.0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.auth.core","purl":null,"source":"GHSA-vcvp-89fq-hwj8"},{"ecosystem":"Maven","fixed":["1.4.2"],"introduced":["1.4.0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.auth.core","purl":"pkg:maven/org.apache.sling/org.apache.sling.auth.core","source":"GHSA-vcvp-89fq-hwj8"}],"prev":{"headline":"Denial of service in Apache Qpid Dispatch Router","id":"CVE-2017-15699"},"products":["Apache Sling"],"published":"2017-12-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"Attackers can trick victims into sending credentials via the Sling login form, leading to account takeover.","url":"https://insights.sbomify.com/CVE-2017-15700/"}