# CVE-2017-15700: Apache Sling Authentication Service vulnerability

> Attackers can trick victims into sending credentials via the Sling login form, leading to account takeover.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Dec 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-vcvp-89fq-hwj8

## What is CVE-2017-15700?

CVE-2017-15700 is a high-severity vulnerability in Apache Sling, published on 18 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw in the org.apache.sling.auth.core.AuthUtil#isRedirectValid method in Apache Sling Authentication Service 1.4.0 allows an attacker, through the Sling login form, to trick a victim to send over their credentials.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-15700?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.auth.core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.auth.core` | Maven | From 1.4.0 | 1.4.2 |
| `org.apache.sling:org.apache.sling.auth.core` | Maven | From 1.4.0 | 1.4.2 |

Products: Apache Sling Authentication Service.

## How do I fix CVE-2017-15700?

Upgrade org.apache.sling:org.apache.sling.auth.core to 1.4.2 or later.

## Is CVE-2017-15700 being exploited?

There is no known exploitation of CVE-2017-15700 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15700 and fix it if it is affected.

What it is: CVE-2017-15700 is a high-severity vulnerability in Apache Sling, published on 18 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-15700 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.auth.core (Maven): affected from 1.4.0; fixed in 1.4.2
- org.apache.sling:org.apache.sling.auth.core (Maven): affected from 1.4.0; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15700/ (Markdown: https://insights.sbomify.com/CVE-2017-15700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15700
- OSV: https://osv.dev/vulnerability/CVE-2017-15700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15700/
Summaries are generated and may contain mistakes; the official description above is the record.
