{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.qpid:qpid-broker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15701 in the wild and no public exploit code.","fix":"Upgrade org.apache.qpid:qpid-broker to 6.1.5 or later.","what":"CVE-2017-15701 is a high-severity vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017."},"fix_prompt":"Check this codebase for CVE-2017-15701 and fix it if it is affected.\n\nWhat it is: CVE-2017-15701 is a high-severity vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. \nExploitation: There is no known exploitation of CVE-2017-15701 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.qpid:qpid-broker (Maven): affected from 6.1.0; fixed in 6.1.5\n- org.apache.qpid:qpid-broker (Maven): affected from 6.1.0; fixed in 6.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15701/ (Markdown: https://insights.sbomify.com/CVE-2017-15701/index.md)","id":"CVE-2017-15701","markdown":"https://insights.sbomify.com/CVE-2017-15701/index.md","name":"CVE-2017-15701","record":{"aliases":["GHSA-4r7g-7cpj-5jr7"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[{"product":"qpid_broker-j","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"In Apache Qpid Broker-J versions 6.1.0 through 6.1.4 (inclusive) the broker does not properly enforce a maximum frame size in AMQP 1.0 frames. A remote unauthenticated attacker could exploit this to cause the broker to exhaust all available memory and eventually terminate. Older AMQP protocols are not affected.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Qpid Broker-J vulnerable to Denial of Service (DoS) via uncontrolled resource consumption","id":"CVE-2017-15701","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Apache Qpid Broker vulnerable to authentication port spoofing","id":"CVE-2017-15702"},"packages":[{"ecosystem":"Maven","fixed":["6.1.5"],"introduced":["6.1.0"],"last_affected":[],"package":"org.apache.qpid:qpid-broker","purl":null,"source":"GHSA-4r7g-7cpj-5jr7"},{"ecosystem":"Maven","fixed":["6.1.5"],"introduced":["6.1.0"],"last_affected":[],"package":"org.apache.qpid:qpid-broker","purl":"pkg:maven/org.apache.qpid/qpid-broker","source":"GHSA-4r7g-7cpj-5jr7"}],"prev":{"headline":"Apache Sling Authentication Service vulnerability","id":"CVE-2017-15700"},"products":["Apache Qpid Broker-J"],"published":"2017-12-01","related":[{"cvss_score":9.8,"headline":"Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication","id":"CVE-2026-92609","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":9.8,"headline":"Apache Qpid Broker vulnerable to authentication port spoofing","id":"CVE-2017-15702","kev_date_added":null,"published":"2017-12-01"},{"cvss_score":9.1,"headline":"AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication","id":"CVE-2016-4432","kev_date_added":null,"published":"2016-06-01"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92550","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92560","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92564","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Apache Qpid Broker-J: Incomplete property conversion handling from AMQP 1.0 to AMQP 0-10","id":"CVE-2026-92608","kev_date_added":null,"published":"2026-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2017-15701/"}