# CVE-2017-15701: Apache Qpid Broker-J vulnerable to Denial of Service (DoS) via uncontrolled resource consumption


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Dec 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4r7g-7cpj-5jr7

## What is CVE-2017-15701?

CVE-2017-15701 is a high-severity vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. 

### Official description

In Apache Qpid Broker-J versions 6.1.0 through 6.1.4 (inclusive) the broker does not properly enforce a maximum frame size in AMQP 1.0 frames. A remote unauthenticated attacker could exploit this to cause the broker to exhaust all available memory and eventually terminate. Older AMQP protocols are not affected.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-15701?

2 open source packages ship an affected version, including org.apache.qpid:qpid-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:qpid-broker` | Maven | From 6.1.0 | 6.1.5 |
| `org.apache.qpid:qpid-broker` | Maven | From 6.1.0 | 6.1.5 |

Products: Apache Qpid Broker-J.

## How do I fix CVE-2017-15701?

Upgrade org.apache.qpid:qpid-broker to 6.1.5 or later.

## Is CVE-2017-15701 being exploited?

There is no known exploitation of CVE-2017-15701 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid Broker-J

- [CVE-2026-92609](https://insights.sbomify.com/CVE-2026-92609/): Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication (critical 9.8)
- [CVE-2017-15702](https://insights.sbomify.com/CVE-2017-15702/): Apache Qpid Broker vulnerable to authentication port spoofing (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15701 and fix it if it is affected.

What it is: CVE-2017-15701 is a high-severity vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. 
Exploitation: There is no known exploitation of CVE-2017-15701 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:qpid-broker (Maven): affected from 6.1.0; fixed in 6.1.5
- org.apache.qpid:qpid-broker (Maven): affected from 6.1.0; fixed in 6.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15701/ (Markdown: https://insights.sbomify.com/CVE-2017-15701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15701
- OSV: https://osv.dev/vulnerability/CVE-2017-15701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15701/
Summaries are generated and may contain mistakes; the official description above is the record.
