{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.qpid:qpid-broker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15702 in the wild and no public exploit code.","fix":"Upgrade org.apache.qpid:qpid-broker to 6.0.0 or later.","what":"CVE-2017-15702 is a critical authentication bypass vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15702 and fix it if it is affected.\n\nWhat it is: CVE-2017-15702 is a critical authentication bypass vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15702 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.qpid:qpid-broker (Maven): affected from 0.18; fixed in 6.0.0\n- org.apache.qpid:qpid-broker (Maven): affected from 0.18; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15702/ (Markdown: https://insights.sbomify.com/CVE-2017-15702/index.md)","id":"CVE-2017-15702","markdown":"https://insights.sbomify.com/CVE-2017-15702/index.md","name":"CVE-2017-15702","record":{"aliases":["GHSA-269m-695x-j34p"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Qpid Broker","requires_auth":"none","summary":"Remote attackers can bypass firewall protections by forcing the broker to use weaker authentication providers configured on other ports.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"qpid_broker-j","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"In Apache Qpid Broker-J 0.18 through 0.32, if the broker is configured with different authentication providers on different ports one of which is an HTTP port, then the broker can be tricked by a remote unauthenticated attacker connecting to the HTTP port into using an authentication provider that was configured on a different port. The attacker still needs valid credentials with the authentication provider on the spoofed port. This becomes an issue when the spoofed port has weaker authentication protection (e.g., anonymous access, default accounts) and is normally protected by firewall rules or similar which can be circumvented by this vulnerability. AMQP ports are not affected. Versions 6.0.0 and newer are not affected.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Qpid Broker vulnerable to authentication port spoofing","id":"CVE-2017-15702","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of service via deserialization attack in nifi","id":"CVE-2017-15703"},"packages":[{"ecosystem":"Maven","fixed":["6.0.0"],"introduced":["0.18"],"last_affected":[],"package":"org.apache.qpid:qpid-broker","purl":null,"source":"GHSA-269m-695x-j34p"},{"ecosystem":"Maven","fixed":["6.0.0"],"introduced":["0.18"],"last_affected":[],"package":"org.apache.qpid:qpid-broker","purl":"pkg:maven/org.apache.qpid/qpid-broker","source":"GHSA-269m-695x-j34p"}],"prev":{"headline":"Apache Qpid Broker-J vulnerable to Denial of Service (DoS) via uncontrolled resource consumption","id":"CVE-2017-15701"},"products":["Apache Qpid Broker-J"],"published":"2017-12-01","related":[{"cvss_score":9.8,"headline":"Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication","id":"CVE-2026-92609","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":9.1,"headline":"AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication","id":"CVE-2016-4432","kev_date_added":null,"published":"2016-06-01"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92550","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92560","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92564","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Apache Qpid Broker-J: Incomplete property conversion handling from AMQP 1.0 to AMQP 0-10","id":"CVE-2026-92608","kev_date_added":null,"published":"2026-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can bypass firewall protections by forcing the broker to use weaker authentication providers configured on other ports.","url":"https://insights.sbomify.com/CVE-2017-15702/"}