# CVE-2017-15702: Apache Qpid Broker vulnerable to authentication port spoofing

> Remote attackers can bypass firewall protections by forcing the broker to use weaker authentication providers configured on other ports.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-269m-695x-j34p

## What is CVE-2017-15702?

CVE-2017-15702 is a critical authentication bypass vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Qpid Broker-J 0.18 through 0.32, if the broker is configured with different authentication providers on different ports one of which is an HTTP port, then the broker can be tricked by a remote unauthenticated attacker connecting to the HTTP port into using an authentication provider that was configured on a different port. The attacker still needs valid credentials with the authentication provider on the spoofed port. This becomes an issue when the spoofed port has weaker authentication protection (e.g., anonymous access, default accounts) and is normally protected by firewall rules or similar which can be circumvented by this vulnerability. AMQP ports are not affected. Versions 6.0.0 and newer are not affected.

## Which versions are affected by CVE-2017-15702?

2 open source packages ship an affected version, including org.apache.qpid:qpid-broker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:qpid-broker` | Maven | From 0.18 | 6.0.0 |
| `org.apache.qpid:qpid-broker` | Maven | From 0.18 | 6.0.0 |

Products: Apache Qpid Broker-J.

## How do I fix CVE-2017-15702?

Upgrade org.apache.qpid:qpid-broker to 6.0.0 or later.

## Is CVE-2017-15702 being exploited?

There is no known exploitation of CVE-2017-15702 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid Broker-J

- [CVE-2026-92609](https://insights.sbomify.com/CVE-2026-92609/): Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92564](https://insights.sbomify.com/CVE-2026-92564/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15702 and fix it if it is affected.

What it is: CVE-2017-15702 is a critical authentication bypass vulnerability in Apache Qpid Broker-J, published on 1 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15702 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:qpid-broker (Maven): affected from 0.18; fixed in 6.0.0
- org.apache.qpid:qpid-broker (Maven): affected from 0.18; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15702/ (Markdown: https://insights.sbomify.com/CVE-2017-15702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15702
- OSV: https://osv.dev/vulnerability/CVE-2017-15702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15702/
Summaries are generated and may contain mistakes; the official description above is the record.
