{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.nifi:nifi-framework-cluster-protocol. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15703 in the wild and no public exploit code.","fix":"Upgrade org.apache.nifi:nifi-framework-cluster-protocol to 1.5.0 or later.","what":"CVE-2017-15703 is a medium-severity unsafe deserialization vulnerability in Apache Nifi, published on 25 Jan 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-15703 and fix it if it is affected.\n\nWhat it is: CVE-2017-15703 is a medium-severity unsafe deserialization vulnerability in Apache Nifi, published on 25 Jan 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-15703 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.nifi:nifi-framework-cluster-protocol (Maven): affected all versions; fixed in 1.5.0\n- org.apache.nifi:nifi-framework-cluster-protocol (Maven): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15703/ (Markdown: https://insights.sbomify.com/CVE-2017-15703/index.md)","id":"CVE-2017-15703","markdown":"https://insights.sbomify.com/CVE-2017-15703/index.md","name":"CVE-2017-15703","record":{"aliases":["GHSA-xwx6-vmj4-5rv8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache NiFi","requires_auth":"low_privilege","summary":"Authenticated users can cause denial of service by uploading malicious templates triggering Java deserialization in Apache NiFi.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Any authenticated user (valid client certificate but without ACL permissions) could upload a template which contained malicious code and caused a denial of service via Java deserialization attack. The fix to properly handle Java deserialization was applied on the Apache NiFi 1.4.0 release. Users running a prior 1.x release should upgrade to the appropriate release.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service via deserialization attack in nifi","id":"CVE-2017-15703","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:nifi","products":["apache:nifi"],"type":"deserialization","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-15704"},"packages":[{"ecosystem":"Maven","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.nifi:nifi-framework-cluster-protocol","purl":null,"source":"GHSA-xwx6-vmj4-5rv8"},{"ecosystem":"Maven","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.nifi:nifi-framework-cluster-protocol","purl":"pkg:maven/org.apache.nifi/nifi-framework-cluster-protocol","source":"GHSA-xwx6-vmj4-5rv8"}],"prev":{"headline":"Apache Qpid Broker vulnerable to authentication port spoofing","id":"CVE-2017-15702"},"products":["Apache NiFi"],"published":"2018-01-25","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can cause denial of service by uploading malicious templates triggering Java deserialization in Apache NiFi.","url":"https://insights.sbomify.com/CVE-2017-15703/"}