# CVE-2017-15707: Moderate severity vulnerability that affects org.apache.struts:struts2-rest-plugin

> Attackers can cause a denial of service in Apache Struts applications by sending specially crafted JSON payloads to the REST plugin.

- **Severity:** Medium 6.2 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xcrm-qpp8-hcw4

## What is CVE-2017-15707?

CVE-2017-15707 is a medium-severity denial of service vulnerability in Apache Struts, published on 1 Dec 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Apache Struts 2.5 to 2.5.14, the REST Plugin is using an outdated JSON-lib library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted JSON payload.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-15707?

2 open source packages ship an affected version, including org.apache.struts:struts2-rest-plugin. It affects 12 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.5.0 | 2.5.16 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.5.0 | 2.5.16 |

Products: Apache Struts, Netapp Oncommand Balance, Oracle Agile Plm Framework, Oracle Enterprise Manager for Virtualization, Oracle Financial Services Hedge Management and Ifrs Valuations, Oracle Financial Services Market Risk Measurement and Management, Oracle Global Lifecycle Management Opatchauto, Oracle Jd Edwards Enterpriseone Tools, Oracle Retail Order Broker, Oracle Retail Xstore Point of Service, Oracle Webcenter Portal, Oracle Weblogic Server.

## How do I fix CVE-2017-15707?

Upgrade org.apache.struts:struts2-rest-plugin to 2.5.16 or later.

## Is CVE-2017-15707 being exploited?

There is no known exploitation of CVE-2017-15707 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15707 and fix it if it is affected.

What it is: CVE-2017-15707 is a medium-severity denial of service vulnerability in Apache Struts, published on 1 Dec 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15707 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.5.0; fixed in 2.5.16
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.5.0; fixed in 2.5.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15707/ (Markdown: https://insights.sbomify.com/CVE-2017-15707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15707
- OSV: https://osv.dev/vulnerability/CVE-2017-15707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15707/
Summaries are generated and may contain mistakes; the official description above is the record.
