{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.synapse:synapse-core. It affects 3 products.","exploited":"There is no known exploitation of CVE-2017-15708 in the wild and no public exploit code.","fix":"Upgrade org.apache.synapse:synapse-core to 3.0.1 or later.","what":"CVE-2017-15708 is a critical unsafe deserialization vulnerability in Oracle Peoplesoft Enterprise Peopletools, published on 11 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15708 and fix it if it is affected.\n\nWhat it is: CVE-2017-15708 is a critical unsafe deserialization vulnerability in Oracle Peoplesoft Enterprise Peopletools, published on 11 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15708 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.synapse:synapse-core (Maven): affected all versions; fixed in 3.0.1\n- org.apache.synapse:synapse-core (Maven): affected all versions; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15708/ (Markdown: https://insights.sbomify.com/CVE-2017-15708/index.md)","id":"CVE-2017-15708","markdown":"https://insights.sbomify.com/CVE-2017-15708/index.md","name":"CVE-2017-15708","record":{"aliases":["GHSA-p694-23q3-rvrc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Synapse","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via deserialization in Apache Synapse due to unauthenticated RMI and vulnerable Commons Collections.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"synapse","vendor":"apache"},{"product":"financial_services_market_risk_measurement_and_management","vendor":"oracle"},{"product":"peoplesoft_enterprise_peopletools","vendor":"oracle"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2017-12-18","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-12-18T10:27:58Z","kind":"github_poc","ref":"https://github.com/HuSoul/CVE-2017-15708","stars":0,"title":"Apache synapse 反序列化 CVE–2017–15708"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Remote Code Execution in Apache Synapse","id":"CVE-2017-15708","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"oracle:peoplesoft_enterprise_peopletools","products":["oracle:peoplesoft_enterprise_peopletools"],"type":"deserialization","year":"2017"},"n_packages":2,"n_references":6,"next":{"headline":"ActiveMQ's OpenWire protocol exposes certain system details as plain text","id":"CVE-2017-15709"},"packages":[{"ecosystem":"Maven","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.synapse:synapse-core","purl":null,"source":"GHSA-p694-23q3-rvrc"},{"ecosystem":"Maven","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.synapse:synapse-core","purl":"pkg:maven/org.apache.synapse/synapse-core","source":"GHSA-p694-23q3-rvrc"}],"prev":{"headline":"Moderate severity vulnerability that affects org.apache.struts:struts2-rest-plugin","id":"CVE-2017-15707"},"products":["Apache Synapse"],"published":"2017-12-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can execute arbitrary code via deserialization in Apache Synapse due to unauthenticated RMI and vulnerable Commons Collections.","url":"https://insights.sbomify.com/CVE-2017-15708/"}