# CVE-2017-15708: Remote Code Execution in Apache Synapse

> Remote attackers can execute arbitrary code via deserialization in Apache Synapse due to unauthenticated RMI and vulnerable Commons Collections.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-p694-23q3-rvrc

## What is CVE-2017-15708?

CVE-2017-15708 is a critical unsafe deserialization vulnerability in Oracle Peoplesoft Enterprise Peopletools, published on 11 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2017-15708?

2 open source packages ship an affected version, including org.apache.synapse:synapse-core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.synapse:synapse-core` | Maven | All versions | 3.0.1 |
| `org.apache.synapse:synapse-core` | Maven | All versions | 3.0.1 |

Products: Apache Synapse, Oracle Financial Services Market Risk Measurement and Management, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2017-15708?

Upgrade org.apache.synapse:synapse-core to 3.0.1 or later.

## Is CVE-2017-15708 being exploited?

There is no known exploitation of CVE-2017-15708 in the wild and no public exploit code.

Public exploit code:

- Apache synapse 反序列化 CVE–2017–15708 (github_poc): https://github.com/HuSoul/CVE-2017-15708

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15708 and fix it if it is affected.

What it is: CVE-2017-15708 is a critical unsafe deserialization vulnerability in Oracle Peoplesoft Enterprise Peopletools, published on 11 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15708 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.synapse:synapse-core (Maven): affected all versions; fixed in 3.0.1
- org.apache.synapse:synapse-core (Maven): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15708/ (Markdown: https://insights.sbomify.com/CVE-2017-15708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15708
- OSV: https://osv.dev/vulnerability/CVE-2017-15708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15708/
Summaries are generated and may contain mistakes; the official description above is the record.
