CVE-2017-15713 Moderate severity vulnerability that affects org.apache.hadoop:hadoop-main

Medium 6.5 Published Updated

A malicious cluster user can exploit XML external entity injection in Hadoop MapReduce to read private files from the job history server host.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-15713?

CVE-2017-15713 is a medium-severity vulnerability in Apache Hadoop, published on 19 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.

Weakness: CWE-200

Which versions are affected by CVE-2017-15713?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-main MavenAll versions2.7.5
org.apache.hadoop:hadoop-main MavenAll versions2.7.5
org.apache.hadoop:hadoop-main MavenFrom 2.8.02.8.3
org.apache.hadoop:hadoop-main MavenFrom 2.8.02.8.3

Products include Apache Hadoop.

How do I fix CVE-2017-15713?

Upgrade org.apache.hadoop:hadoop-main to a fixed version for your release line: 2.7.5 or 2.8.3.

Is CVE-2017-15713 being exploited?

There is no known exploitation of CVE-2017-15713 in the wild and no public exploit code.

Sources

Also known as GHSA-3v44-382q-55f4.

Is CVE-2017-15713 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free