# CVE-2017-15713: Moderate severity vulnerability that affects org.apache.hadoop:hadoop-main

> A malicious cluster user can exploit XML external entity injection in Hadoop MapReduce to read private files from the job history server host.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-3v44-382q-55f4

## What is CVE-2017-15713?

CVE-2017-15713 is a medium-severity vulnerability in Apache Hadoop, published on 19 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-15713?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-main` | Maven | All versions | 2.7.5 |
| `org.apache.hadoop:hadoop-main` | Maven | All versions | 2.7.5 |
| `org.apache.hadoop:hadoop-main` | Maven | From 2.8.0 | 2.8.3 |
| `org.apache.hadoop:hadoop-main` | Maven | From 2.8.0 | 2.8.3 |

Products: Apache Hadoop.

## How do I fix CVE-2017-15713?

Upgrade org.apache.hadoop:hadoop-main to a fixed version for your release line: 2.7.5 or 2.8.3.

## Is CVE-2017-15713 being exploited?

There is no known exploitation of CVE-2017-15713 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15713 and fix it if it is affected.

What it is: CVE-2017-15713 is a medium-severity vulnerability in Apache Hadoop, published on 19 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15713 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-main (Maven): affected all versions; fixed in 2.7.5
- org.apache.hadoop:hadoop-main (Maven): affected all versions; fixed in 2.7.5
- org.apache.hadoop:hadoop-main (Maven): affected from 2.8.0; fixed in 2.8.3
- org.apache.hadoop:hadoop-main (Maven): affected from 2.8.0; fixed in 2.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15713/ (Markdown: https://insights.sbomify.com/CVE-2017-15713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15713
- OSV: https://osv.dev/vulnerability/CVE-2017-15713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15713/
Summaries are generated and may contain mistakes; the official description above is the record.
