{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15718 in the wild and no public exploit code.","fix":"Upgrade org.apache.hadoop:hadoop-main to 2.7.5 or later.","what":"CVE-2017-15718 is a critical vulnerability in Apache Hadoop, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15718 and fix it if it is affected.\n\nWhat it is: CVE-2017-15718 is a critical vulnerability in Apache Hadoop, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.hadoop:hadoop-main (Maven): affected from 2.7.3; fixed in 2.7.5\n- org.apache.hadoop:hadoop-main (Maven): affected from 2.7.3; fixed in 2.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15718/ (Markdown: https://insights.sbomify.com/CVE-2017-15718/index.md)","id":"CVE-2017-15718","markdown":"https://insights.sbomify.com/CVE-2017-15718/index.md","name":"CVE-2017-15718","record":{"aliases":["GHSA-mq8p-h798-xcrp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Hadoop YARN NodeManager","requires_auth":"none","summary":"YARN NodeManager leaks credential store passwords to YARN Applications, allowing attackers to read sensitive authentication data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"hadoop","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"The YARN NodeManager in Apache Hadoop 2.7.3 and 2.7.4 can leak the password for credential store provider used by the NodeManager to YARN Applications.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information in Hadoop","id":"CVE-2017-15718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site Scripting in wicket-jquery-ui","id":"CVE-2017-15719"},"packages":[{"ecosystem":"Maven","fixed":["2.7.5"],"introduced":["2.7.3"],"last_affected":[],"package":"org.apache.hadoop:hadoop-main","purl":null,"source":"GHSA-mq8p-h798-xcrp"},{"ecosystem":"Maven","fixed":["2.7.5"],"introduced":["2.7.3"],"last_affected":[],"package":"org.apache.hadoop:hadoop-main","purl":"pkg:maven/org.apache.hadoop/hadoop-main","source":"GHSA-mq8p-h798-xcrp"}],"prev":{"headline":"Cross-site Scripting in Apache Sling XSS Protection API","id":"CVE-2017-15717"},"products":["Apache Hadoop"],"published":"2018-01-24","related":[{"cvss_score":9.8,"headline":"Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar","id":"CVE-2022-25168","kev_date_added":null,"published":"2022-08-04"},{"cvss_score":9.8,"headline":"Heap buffer overflow in libhdfs native library","id":"CVE-2021-37404","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9.8,"headline":"Arbitrary file write in FileUtil#unpackEntries on Windows","id":"CVE-2022-26612","kev_date_added":null,"published":"2022-04-07"},{"cvss_score":9.8,"headline":"Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT","id":"CVE-2019-17195","kev_date_added":null,"published":"2019-10-15"},{"cvss_score":9.8,"headline":"Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop","id":"CVE-2012-4449","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":9.8,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop","id":"CVE-2016-3086","kev_date_added":null,"published":"2017-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"YARN NodeManager leaks credential store passwords to YARN Applications, allowing attackers to read sensitive authentication data.","url":"https://insights.sbomify.com/CVE-2017-15718/"}