{"answers":{"affected":"6 open source packages ship an affected version, including com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15719 in the wild and no public exploit code.","fix":"Upgrade com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent to a fixed version for your release line: 6.28.1, 7.9.2 or 8.0.0-M8.1.","what":"CVE-2017-15719 is a medium-severity cross-site scripting vulnerability in Apache Software Foundation Wicket jQuery UI, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-15719 and fix it if it is affected.\n\nWhat it is: CVE-2017-15719 is a medium-severity cross-site scripting vulnerability in Apache Software Foundation Wicket jQuery UI, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-15719 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected all versions; fixed in 6.28.1\n- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected all versions; fixed in 6.28.1\n- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 7.0.0; fixed in 7.9.2\n- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 7.0.0; fixed in 7.9.2\n- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 8.0.0-M1; fixed in 8.0.0-M8.1\n- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 8.0.0-M1; fixed in 8.0.0-M8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15719/ (Markdown: https://insights.sbomify.com/CVE-2017-15719/index.md)","id":"CVE-2017-15719","markdown":"https://insights.sbomify.com/CVE-2017-15719/index.md","name":"CVE-2017-15719","record":{"aliases":["GHSA-pwpc-hqq2-hx2x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Attackers can inject arbitrary JavaScript into the Wicket jQuery UI WYSIWYG editor, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"wicket-jquery-ui","vendor":"wicket-jquery-ui_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in wicket-jquery-ui","id":"CVE-2017-15719","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":6,"n_references":2,"next":{"headline":"Improper Input Validation in Apache Airflow resulting in Remote Code Execution","id":"CVE-2017-15720"},"packages":[{"ecosystem":"Maven","fixed":["6.28.1"],"introduced":["0"],"last_affected":[],"package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","purl":null,"source":"GHSA-pwpc-hqq2-hx2x"},{"ecosystem":"Maven","fixed":["6.28.1"],"introduced":["0"],"last_affected":[],"package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","purl":"pkg:maven/com.googlecode.wicket-jquery-ui/wicket-jquery-ui-parent","source":"GHSA-pwpc-hqq2-hx2x"},{"ecosystem":"Maven","fixed":["7.9.2"],"introduced":["7.0.0"],"last_affected":[],"package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","purl":null,"source":"GHSA-pwpc-hqq2-hx2x"},{"ecosystem":"Maven","fixed":["7.9.2"],"introduced":["7.0.0"],"last_affected":[],"package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","purl":"pkg:maven/com.googlecode.wicket-jquery-ui/wicket-jquery-ui-parent","source":"GHSA-pwpc-hqq2-hx2x"},{"ecosystem":"Maven","fixed":["8.0.0-M8.1"],"introduced":["8.0.0-M1"],"last_affected":[],"package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","purl":null,"source":"GHSA-pwpc-hqq2-hx2x"},{"ecosystem":"Maven","fixed":["8.0.0-M8.1"],"introduced":["8.0.0-M1"],"last_affected":[],"package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","purl":"pkg:maven/com.googlecode.wicket-jquery-ui/wicket-jquery-ui-parent","source":"GHSA-pwpc-hqq2-hx2x"}],"prev":{"headline":"Exposure of Sensitive Information in Hadoop","id":"CVE-2017-15718"},"products":["Wicket jQuery UI"],"published":"2018-03-12","related":[{"cvss_score":6.1,"headline":"Cross-site Scripting in wicket-jquery-ui","id":"CVE-2018-1325","kev_date_added":null,"published":"2018-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject arbitrary JavaScript into the Wicket jQuery UI WYSIWYG editor, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2017-15719/"}