# CVE-2017-15719: Cross-site Scripting in wicket-jquery-ui

> Attackers can inject arbitrary JavaScript into the Wicket jQuery UI WYSIWYG editor, potentially compromising user sessions or data.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-pwpc-hqq2-hx2x

## What is CVE-2017-15719?

CVE-2017-15719 is a medium-severity cross-site scripting vulnerability in Apache Software Foundation Wicket jQuery UI, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-15719?

6 open source packages ship an affected version, including com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent` | Maven | All versions | 6.28.1 |
| `com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent` | Maven | All versions | 6.28.1 |
| `com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent` | Maven | From 7.0.0 | 7.9.2 |
| `com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent` | Maven | From 7.0.0 | 7.9.2 |
| `com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent` | Maven | From 8.0.0-M1 | 8.0.0-M8.1 |
| `com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent` | Maven | From 8.0.0-M1 | 8.0.0-M8.1 |

Products: Wicket-Jquery-Ui Project Wicket-Jquery-Ui.

## How do I fix CVE-2017-15719?

Upgrade com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent to a fixed version for your release line: 6.28.1, 7.9.2 or 8.0.0-M8.1.

## Is CVE-2017-15719 being exploited?

There is no known exploitation of CVE-2017-15719 in the wild and no public exploit code.

## Other vulnerabilities in Apache Software Foundation Wicket jQuery UI

- [CVE-2018-1325](https://insights.sbomify.com/CVE-2018-1325/): Cross-site Scripting in wicket-jquery-ui (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15719 and fix it if it is affected.

What it is: CVE-2017-15719 is a medium-severity cross-site scripting vulnerability in Apache Software Foundation Wicket jQuery UI, published on 12 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-15719 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected all versions; fixed in 6.28.1
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected all versions; fixed in 6.28.1
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 7.0.0; fixed in 7.9.2
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 7.0.0; fixed in 7.9.2
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 8.0.0-M1; fixed in 8.0.0-M8.1
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent (Maven): affected from 8.0.0-M1; fixed in 8.0.0-M8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15719/ (Markdown: https://insights.sbomify.com/CVE-2017-15719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15719
- OSV: https://osv.dev/vulnerability/CVE-2017-15719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15719/
Summaries are generated and may contain mistakes; the official description above is the record.
